1SUMMARY = "Makes working with XML feel like you are working with JSON"
2HOMEPAGE = "https://github.com/martinblech/xmltodict"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=01441d50dc74476db58a41ac10cb9fa2"
5
6SRC_URI[sha256sum] = "341595a488e3e01a85a9d8911d8912fd922ede5fecc4dce437eb4b6c8d037e56"
7
8PYPI_PACKAGE = "xmltodict"
9
10BBCLASSEXTEND = "native nativesdk"
11
12inherit pypi setuptools3 ptest
13
14SRC_URI += " \
15	file://run-ptest \
16"
17
18RDEPENDS:${PN} += " \
19	python3-core \
20	python3-xml \
21	python3-io \
22"
23
24RDEPENDS:${PN}-ptest += " \
25	python3-pytest \
26"
27
28do_install_ptest() {
29	install -d ${D}${PTEST_PATH}/tests
30	cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
31}
32