1SUMMARY = "Setuptools Rust extension plugin"
2DESCRIPTION = "setuptools-rust is a plugin for setuptools to build Rust \
3Python extensions implemented with PyO3 or rust-cpython.\
4\
5Compile and distribute Python extensions written in Rust as easily as if they were written in C."
6HOMEPAGE = "https://github.com/PyO3/setuptools-rust"
7BUGTRACKER = "https://github.com/PyO3/setuptools-rust/issues"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=011cd92e702dd9e6b1a26157b6fd53f5"
11
12SRC_URI[sha256sum] = "5d73e7eee5f87a6417285b617c97088a7c20d1a70fcea60e3bdc94ff567c29dc"
13
14PYPI_PACKAGE = "setuptools_rust"
15
16inherit cargo pypi python_setuptools_build_meta
17
18DEPENDS += "python3-setuptools-scm-native python3-wheel-native"
19
20RDEPENDS:${PN} += " \
21    python3-json \
22    python3-semantic-version \
23    python3-setuptools \
24    python3-setuptools-scm \
25    python3-shell \
26    python3-typing-extensions \
27    python3-wheel \
28"
29
30BBCLASSEXTEND = "native nativesdk"
31