xref: /openbmc/openbmc/poky/meta/recipes-devtools/python/python3-semantic-version_2.10.0.bb (revision bec4ebc22c43c1ff5c3fddb820d44a88bd3aebf0)
1SUMMARY  = "A library implementing the 'SemVer' scheme."
2DESCRIPTION = "Semantic version comparison for Python (see http://semver.org/)"
3HOMEPAGE = "https://github.com/rbarrois/python-semanticversion"
4LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4fb31e3c1c7eeb8b5e8c07657cdd54e2"
6
7SRC_URI[sha256sum] = "bdabb6d336998cbb378d4b9db3a4b56a1e3235701dc05ea2690d9a997ed5041c"
8
9PYPI_PACKAGE = "semantic_version"
10inherit pypi setuptools3
11
12RDEPENDS:${PN} += " \
13    ${PYTHON_PN}-pkg-resources \
14"
15
16BBCLASSEXTEND = "native nativesdk"
17
18UPSTREAM_CHECK_REGEX = "/semantic-version/(?P<pver>(\d+[\.\-_]*)+)/"
19