1SUMMARY = "World timezone definitions, modern and historical"
2HOMEPAGE = "http://pythonhosted.org/pytz"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999"
5
6inherit pypi setuptools3 ptest
7
8SRC_URI[sha256sum] = "2aa355083c50a0f93fa581709deac0c9ad65cca8a9e9beac660adcbd493c798a"
9
10RDEPENDS:${PN}:class-target += "\
11    python3-datetime \
12    python3-doctest \
13    python3-io \
14    python3-pickle \
15    python3-pprint \
16    python3-threading \
17"
18
19BBCLASSEXTEND = "native nativesdk"
20
21SRC_URI += " \
22	file://run-ptest \
23"
24
25RDEPENDS:${PN}-ptest += " \
26	python3-pytest \
27	python3-unittest-automake-output \
28"
29
30do_install_ptest() {
31	install -d ${D}${PTEST_PATH}/pytz
32	install -d ${D}${PTEST_PATH}/pytz/tests
33	cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
34	cp -f ${S}/README.rst ${D}${PTEST_PATH}/
35
36}
37