1SUMMARY = "A cross-platform process and system utilities module for Python"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=a9c72113a843d0d732a0ac1c200d81b1"
4HOMEPAGE = "https://pypi.org/project/psutil/"
5
6SRC_URI[sha256sum] = "6be126e3225486dff286a8fb9a06246a5253f4c7c53b475ea5f5ac934e64194c"
7
8inherit pypi setuptools3
9
10PACKAGES =+ "${PN}-tests"
11
12FILES:${PN}-tests += " \
13    ${PYTHON_SITEPACKAGES_DIR}/psutil/test* \
14    ${PYTHON_SITEPACKAGES_DIR}/psutil/__pycache__/test* \
15"
16
17
18RDEPENDS:${PN} += " \
19    python3-shell \
20    python3-threading \
21    python3-xml \
22    python3-netclient \
23    python3-ctypes \
24    python3-resource \
25"
26
27RDEPENDS:${PN}-tests += " \
28     ${PN} \
29     python3 \
30     coreutils \
31     procps \
32     binutils \
33     gcc \
34     gcc-symlinks \
35     libstdc++ \
36     libstdc++-dev \
37"
38
39INSANE_SKIP:${PN}-tests += "dev-deps"
40
41BBCLASSEXTEND = "native"
42