1SUMMARY = "Poetry PEP 517 Build Backend"
2DESCRIPTION = "Poetry PEP 517 Build Backend"
3HOMEPAGE = "https://github.com/python-poetry/poetry-core"
4BUGTRACKER = "https://github.com/python-poetry/poetry-core"
5CHANGELOG = "https://github.com/python-poetry/poetry-core/blob/master/CHANGELOG.md"
6
7LICENSE = "Apache-2.0 & BSD-2-Clause & BSD-3-Clause & MIT"
8LIC_FILES_CHKSUM = "\
9    file://LICENSE;md5=78c39cfd009863ae44237a7ab1f9cedc \
10    file://src/poetry/core/_vendor/fastjsonschema/LICENSE;md5=18950e8362b69c0c617b42b8bd8e7532 \
11    file://src/poetry/core/_vendor/lark/LICENSE;md5=fcfbf1e2ecc0f37acbb5871aa0267500 \
12    file://src/poetry/core/_vendor/packaging/LICENSE;md5=faadaedca9251a90b205c9167578ce91 \
13    file://src/poetry/core/_vendor/packaging/LICENSE.APACHE;md5=2ee41112a44fe7014dce33e26468ba93 \
14    file://src/poetry/core/_vendor/packaging/LICENSE.BSD;md5=7bef9bf4a8e4263634d0597e7ba100b8 \
15    file://src/poetry/core/_vendor/tomli/LICENSE;md5=aaaaf0879d17df0110d1aa8c8c9f46f5 \
16"
17
18SRC_URI[sha256sum] = "fa7a4001eae8aa572ee84f35feb510b321bd652e5cf9293249d62853e1f935a2"
19
20inherit python_poetry_core pypi
21
22PYPI_PACKAGE = "poetry_core"
23
24RDEPENDS:${PN}:append:class-target = "\
25    python3-compression \
26    python3-core \
27    python3-crypt \
28    python3-io \
29    python3-json \
30    python3-logging \
31    python3-netclient \
32    python3-pathlib2 \
33    python3-pprint \
34    python3-shell \
35"
36
37RDEPENDS:${PN} += "\
38    python3-pip \
39    python3-six \
40"
41
42BBCLASSEXTEND = "native nativesdk"
43