1SUMMARY = "Plugin and hook calling mechanisms for python"
2HOMEPAGE = "https://github.com/pytest-dev/pluggy"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1c8206d16fd5cc02fa9b0bb98955e5c2"
5
6SRC_URI[sha256sum] = "8c85c2876142a764e5b7548e7d9a0e0ddb46f5185161049a79b7e974454223be"
7
8DEPENDS += "python3-setuptools-scm-native"
9RDEPENDS:${PN} += "python3-importlib-metadata \
10                   python3-more-itertools \
11"
12
13inherit pypi ptest python_setuptools_build_meta
14
15SRC_URI += " \
16	file://run-ptest \
17"
18
19RDEPENDS:${PN}-ptest += " \
20	python3-pytest \
21	python3-unittest-automake-output \
22"
23
24do_install_ptest() {
25	install -d ${D}${PTEST_PATH}/testing
26	cp -rf ${S}/testing/* ${D}${PTEST_PATH}/testing/
27}
28
29BBCLASSEXTEND = "native nativesdk"
30