1SUMMARY = "Implements a XML/HTML/XHTML Markup safe string for Python"
2HOMEPAGE = "http://github.com/mitsuhiko/markupsafe"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
5
6SRC_URI[sha256sum] = "ee55d3edf80167e48ea11a923c7386f4669df67d7994554387f84e7d8b0a2bf0"
7
8PYPI_PACKAGE = "markupsafe"
9UPSTREAM_CHECK_PYPI_PACKAGE = "MarkupSafe"
10inherit pypi python_setuptools_build_meta ptest
11
12RDEPENDS:${PN} += "python3-html python3-stringold"
13
14BBCLASSEXTEND = "native nativesdk"
15
16SRC_URI += " \
17	file://run-ptest \
18"
19
20RDEPENDS:${PN}-ptest += " \
21	python3-pytest \
22	python3-unittest-automake-output \
23"
24
25do_install_ptest() {
26	install -d ${D}${PTEST_PATH}/tests
27	cp -f ${S}/tests/* ${D}${PTEST_PATH}/tests/
28}
29