1SUMMARY = "Implements a XML/HTML/XHTML Markup safe string for Python"
2HOMEPAGE = "http://github.com/mitsuhiko/markupsafe"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
5
6SRC_URI[sha256sum] = "d283d37a890ba4c1ae73ffadf8046435c76e7bc2247bbb63c00bd1a709c6544b"
7
8PYPI_PACKAGE = "MarkupSafe"
9inherit pypi python_setuptools_build_meta ptest
10
11RDEPENDS:${PN} += "python3-stringold"
12
13BBCLASSEXTEND = "native nativesdk"
14
15SRC_URI += " \
16	file://run-ptest \
17"
18
19RDEPENDS:${PN}-ptest += " \
20	python3-pytest \
21	python3-unittest-automake-output \
22"
23
24do_install_ptest() {
25	install -d ${D}${PTEST_PATH}/tests
26	cp -f ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}
28