1SUMMARY = "The extensible, standards compliant build backend used by Hatch"
2HOMEPAGE = "https://hatch.pypa.io/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cbe2fd33fc9297692812fc94b7d27fd9"
5
6inherit pypi python_hatchling
7
8DEPENDS += "python3-pluggy-native python3-pathspec-native python3-packaging-native python3-editables-native python3-trove-classifiers-native"
9DEPENDS:remove:class-native = "python3-hatchling-native"
10
11SRC_URI[sha256sum] = "8a2dcec96d7fb848382ef5848e5ac43fdae641f35a08a3fab5116bd495f3416e"
12
13do_compile:prepend() {
14    export PYTHONPATH=src
15}
16
17BBCLASSEXTEND = "native nativesdk"
18