1SUMMARY = "Provides cryptographic recipes and primitives to python developers"
2HOMEPAGE = "https://cryptography.io/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0 | BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4 \
6                    file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \
7                    file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b \
8                   "
9LDSHARED += "-pthread"
10
11SRC_URI[sha256sum] = "6fe07eec95dfd477eb9530aef5bead34fec819b3aaf6c5bd6d20565da607bfe1"
12
13SRC_URI += "file://0001-pyproject.toml-remove-benchmark-disable-option.patch \
14            file://check-memfree.py \
15            file://run-ptest \
16           "
17
18require ${BPN}-crates.inc
19
20inherit pypi python_setuptools3_rust cargo-update-recipe-crates pkgconfig
21
22DEPENDS += " \
23    python3-cffi-native \
24"
25
26RDEPENDS:${PN} += " \
27    python3-cffi \
28"
29
30RDEPENDS:${PN}:append:class-target = " \
31    python3-numbers \
32    python3-threading \
33"
34
35RDEPENDS:${PN}-ptest += " \
36    python3-bcrypt \
37    python3-cryptography-vectors (= ${PV}) \
38    python3-hypothesis \
39    python3-iso8601 \
40    python3-mmap \
41    python3-pretend \
42    python3-psutil \
43    python3-pytest \
44    python3-unittest-automake-output \
45    python3-pytest-subtests \
46    python3-pytz \
47"
48
49inherit ptest
50
51do_install_ptest() {
52    install -D ${WORKDIR}/check-memfree.py ${D}${PTEST_PATH}/
53    install -d ${D}${PTEST_PATH}/tests
54    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
55    # remove test_x509.py as it needs benchmark and we don't
56    # want to introduce the benchmark dependency
57    rm -rf ${D}${PTEST_PATH}/tests/bench/test_x509.py
58    install -d ${D}${PTEST_PATH}/tests/hazmat
59    cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
60    cp -r ${S}/pyproject.toml ${D}${PTEST_PATH}/
61}
62
63FILES:${PN}-dbg += " \
64    ${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/hazmat/bindings/.debug \
65"
66
67BBCLASSEXTEND = "native nativesdk"
68