1SUMMARY = "Foreign Function Interface for Python calling C code"
2HOMEPAGE = "http://cffi.readthedocs.org/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf"
5DEPENDS += "libffi python3-pycparser"
6
7SRC_URI[sha256sum] = "bcb3ef43e58665bbda2fb198698fcae6776483e0c4a631aa5647806c25e02cc0"
8
9inherit pypi setuptools3
10
11RDEPENDS:${PN}:class-target = " \
12    python3-ctypes \
13    python3-io \
14    python3-pycparser \
15    python3-shell \
16"
17
18BBCLASSEXTEND = "native nativesdk"
19