1SUMMARY = "Classes Without Boilerplate"
2HOMEPAGE = "http://www.attrs.org/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5e55731824cf9205cfabeab9a0600887"
5
6SRC_URI[sha256sum] = "935dc3b529c262f6cf76e50877d35a4bd3c1de194fd41f47a2b7ae8f19971f30"
7
8inherit pypi ptest python_hatchling
9
10SRC_URI += " \
11	file://0001-test_funcs-skip-test_unknown-for-pytest-8.patch \
12	file://0001-conftest.py-disable-deadline.patch \
13	file://run-ptest \
14"
15
16DEPENDS += " \
17    python3-hatch-vcs-native \
18    python3-hatch-fancy-pypi-readme-native \
19"
20
21RDEPENDS:${PN}+= " \
22    python3-compression \
23    python3-ctypes \
24    python3-crypt \
25"
26
27RDEPENDS:${PN}-ptest += " \
28    python3-hypothesis \
29    python3-pytest \
30    python3-unittest-automake-output \
31"
32
33do_install_ptest() {
34    install -d ${D}${PTEST_PATH}/tests
35    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
36    install ${S}/conftest.py ${D}${PTEST_PATH}/
37}
38
39BBCLASSEXTEND = "native nativesdk"
40