1SUMMARY = "Powerful Python library for atomic file writes"
2HOMEPAGE = "https://github.com/untitaker/python-atomicwrites"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=91cc36cfafeefb7863673bcfcb1d4da4"
5
6SRC_URI[sha256sum] = "81b2c9071a49367a7f770170e5eec8cb66567cfbbc8c73d20ce5ca4a8d71cf11"
7
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11	file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15	${PYTHON_PN}-pytest \
16	${PYTHON_PN}-unittest-automake-output \
17	${PYTHON_PN}-unixadmin \
18"
19
20do_install_ptest() {
21	install -d ${D}${PTEST_PATH}/tests
22	cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
24
25RDEPENDS:${PN} = "${PYTHON_PN}-misc"
26
27BBCLASSEXTEND = "native nativesdk"
28