1require pseudo.inc
2
3SRC_URI = "git://git.yoctoproject.org/pseudo;branch=master;protocol=https \
4           file://0001-configure-Prune-PIE-flags.patch \
5           file://fallback-passwd \
6           file://fallback-group \
7           "
8SRC_URI:append:class-native = " \
9    http://downloads.yoctoproject.org/mirror/sources/pseudo-prebuilt-2.33.tar.xz;subdir=git/prebuilt;name=prebuilt \
10    file://older-glibc-symbols.patch"
11SRC_URI:append:class-nativesdk = " \
12    http://downloads.yoctoproject.org/mirror/sources/pseudo-prebuilt-2.33.tar.xz;subdir=git/prebuilt;name=prebuilt \
13    file://older-glibc-symbols.patch"
14SRC_URI[prebuilt.sha256sum] = "ed9f456856e9d86359f169f46a70ad7be4190d6040282b84c8d97b99072485aa"
15
16SRCREV = "ec6151a2b057109b3f798f151a36690af582e166"
17S = "${WORKDIR}/git"
18PV = "1.9.0+git${SRCPV}"
19
20# largefile and 64bit time_t support adds these macros via compiler flags globally
21# remove them for pseudo since pseudo intercepts some of the functions which will be
22# aliased due to this e.g. open/open64 and it will complain about duplicate definitions
23# pseudo on 32bit systems is not much of use anyway and these features are not of much
24# use for it.
25TARGET_CC_ARCH:remove = "-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_TIME_BITS=64"
26
27# error: use of undeclared identifier '_STAT_VER'
28COMPATIBLE_HOST:libc-musl = 'null'
29