1SUMMARY = "Ninja is a small build system with a focus on speed."
2HOMEPAGE = "https://ninja-build.org/"
3DESCRIPTION = "Ninja is a small build system with a focus on speed. It differs from other build systems in two major respects: it is designed to have its input files generated by a higher-level build system, and it is designed to run builds as fast as possible."
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
6
7DEPENDS = "re2c-native ninja-native"
8
9SRCREV = "a524bf3f6bacd1b4ad85d719eed2737d8562f27a"
10
11SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release;protocol=https"
12UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
13
14S = "${WORKDIR}/git"
15
16do_configure[noexec] = "1"
17
18do_compile:class-native() {
19	python3 ./configure.py --bootstrap
20}
21
22do_compile() {
23	python3 ./configure.py
24	ninja
25}
26
27do_install() {
28	install -D -m 0755  ${S}/ninja ${D}${bindir}/ninja
29}
30
31BBCLASSEXTEND = "native nativesdk"
32
33CVE_STATUS[CVE-2021-4336] = "cpe-incorrect: This is a different Ninja"
34