1SUMMARY = "Userspace tools for MMC/SD devices"
2HOMEPAGE = "http://git.kernel.org/cgit/linux/kernel/git/cjb/mmc-utils.git/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://mmc.c;beginline=1;endline=20;md5=fae32792e20f4d27ade1c5a762d16b7d"
5
6SRCBRANCH ?= "master"
7SRCREV = "aef913e31b659462fe6b9320d241676cba97f67b"
8
9PV = "0.1+git${SRCPV}"
10
11SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git;branch=${SRCBRANCH} \
12           "
13UPSTREAM_CHECK_COMMITS = "1"
14
15S = "${WORKDIR}/git"
16
17CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
18CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
19CFLAGS_append_mipsarchn32 = " -D__SANE_USERSPACE_TYPES__"
20
21do_install() {
22    install -d ${D}${bindir}
23    install -m 0755 mmc ${D}${bindir}
24}
25