1SUMMARY = "Userspace tools for MMC/SD devices"
2HOMEPAGE = "https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git/"
3DESCRIPTION = "${SUMMARY}"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://mmc.c;beginline=1;endline=20;md5=fae32792e20f4d27ade1c5a762d16b7d"
6
7SRCBRANCH ?= "master"
8SRCREV = "523d8f3cfb219d800f45860892e742e3a355f1bb"
9
10PV = "0.1+git"
11
12SRC_URI = "git://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git;branch=${SRCBRANCH};protocol=https"
13UPSTREAM_CHECK_COMMITS = "1"
14
15DEPENDS = "python3-sphinx-native"
16EXTRA_OEMAKE = "C="
17
18S = "${WORKDIR}/git"
19
20CFLAGS:append:powerpc64 = " -D__SANE_USERSPACE_TYPES__"
21CFLAGS:append:mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
22CFLAGS:append:mipsarchn32 = " -D__SANE_USERSPACE_TYPES__"
23
24do_install() {
25    install -d ${D}${bindir}
26    install -m 0755 mmc ${D}${bindir}
27}
28