xref: /openbmc/openbmc/poky/meta/recipes-devtools/mmc/mmc-utils_git.bb (revision 8460358c3d24c71d9d38fd126c745854a6301564)
1eb8dc403SDave CobbleySUMMARY = "Userspace tools for MMC/SD devices"
2edff4923SAndrew GeisslerHOMEPAGE = "https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git/"
390fd73cbSAndrew GeisslerDESCRIPTION = "${SUMMARY}"
47e0e3c0cSAndrew GeisslerLICENSE = "GPL-2.0-only"
5eb8dc403SDave CobbleyLIC_FILES_CHKSUM = "file://mmc.c;beginline=1;endline=20;md5=fae32792e20f4d27ade1c5a762d16b7d"
6eb8dc403SDave Cobbley
7eb8dc403SDave CobbleySRCBRANCH ?= "master"
8*8460358cSPatrick WilliamsSRCREV = "523d8f3cfb219d800f45860892e742e3a355f1bb"
9eb8dc403SDave Cobbley
105082cc7fSAndrew GeisslerPV = "0.1+git"
11eb8dc403SDave Cobbley
12edff4923SAndrew GeisslerSRC_URI = "git://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git;branch=${SRCBRANCH};protocol=https"
13eb8dc403SDave CobbleyUPSTREAM_CHECK_COMMITS = "1"
14eb8dc403SDave Cobbley
15*8460358cSPatrick WilliamsDEPENDS = "python3-sphinx-native"
16*8460358cSPatrick WilliamsEXTRA_OEMAKE = "C="
17*8460358cSPatrick Williams
18eb8dc403SDave CobbleyS = "${WORKDIR}/git"
19eb8dc403SDave Cobbley
20213cb269SPatrick WilliamsCFLAGS:append:powerpc64 = " -D__SANE_USERSPACE_TYPES__"
21213cb269SPatrick WilliamsCFLAGS:append:mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
22213cb269SPatrick WilliamsCFLAGS:append:mipsarchn32 = " -D__SANE_USERSPACE_TYPES__"
23eb8dc403SDave Cobbley
24eb8dc403SDave Cobbleydo_install() {
25eb8dc403SDave Cobbley    install -d ${D}${bindir}
26eb8dc403SDave Cobbley    install -m 0755 mmc ${D}${bindir}
27eb8dc403SDave Cobbley}
28