1SUMMARY = "Utility scripts for internationalizing XML"
2HOMEPAGE = "https://launchpad.net/intltool"
3DESCRIPTION = "Utility scripts for internationalizing XML. This tool automatically extracts translatable strings from oaf, glade, bonobo ui, nautilus theme and other XML files into the po files."
4SECTION = "devel"
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8SRC_URI = "http://launchpad.net/${BPN}/trunk/${PV}/+download/${BP}.tar.gz \
9           file://intltool-nowarn.patch \
10           file://perl-522-deprecations.patch \
11           file://remove-perl-check.patch \
12           file://noperlcheck.patch \
13           "
14SRC_URI[md5sum] = "12e517cac2b57a0121cda351570f1e63"
15SRC_URI[sha256sum] = "67c74d94196b153b774ab9f89b2fa6c6ba79352407037c8c14d5aeb334e959cd"
16
17UPSTREAM_CHECK_URI = "https://launchpad.net/intltool/trunk/"
18
19DEPENDS = "libxml-parser-perl-native"
20RDEPENDS:${PN} = "gettext-dev libxml-parser-perl"
21DEPENDS:class-native = "libxml-parser-perl-native gettext-native"
22
23inherit autotools pkgconfig perlnative
24
25export PERL = "${bindir}/env perl"
26PERL:class-native = "/usr/bin/env nativeperl"
27PERL:class-nativesdk = "/usr/bin/env perl"
28
29# gettext is assumed to exist on the host
30RDEPENDS:${PN}:class-native = "libxml-parser-perl-native"
31RRECOMMENDS:${PN} = "perl-modules"
32RRECOMMENDS:${PN}:class-native = ""
33
34FILES:${PN}-dev = ""
35FILES:${PN} += "${datadir}/aclocal"
36
37INSANE_SKIP:${PN} += "dev-deps"
38
39BBCLASSEXTEND = "native nativesdk"
40