1require go-${PV}.inc
2require go-target.inc
3
4inherit linuxloader
5
6CGO_LDFLAGS:append = " -no-pie"
7
8export GO_LDSO = "${@get_linuxloader(d)}"
9export CC_FOR_TARGET = "gcc"
10export CXX_FOR_TARGET = "g++"
11
12# mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv32 and its
13# variants.
14python() {
15    if 'mips' in d.getVar('TARGET_ARCH') or 'riscv32' in d.getVar('TARGET_ARCH'):
16        d.appendVar('INSANE_SKIP:%s' % d.getVar('PN'), " textrel")
17}
18
19