1SUMMARY = "Flex (The Fast Lexical Analyzer)"
2DESCRIPTION = "Flex is a fast lexical analyser generator.  Flex is a tool for generating programs that recognize \
3lexical patterns in text."
4HOMEPAGE = "http://sourceforge.net/projects/flex/"
5SECTION = "devel"
6LICENSE = "BSD-3-Clause & LGPL-2.0-or-later"
7LICENSE:${PN}-libfl = "BSD-3-Clause"
8
9DEPENDS = "${@bb.utils.contains('PTEST_ENABLED', '1', 'bison-native flex-native', '', d)}"
10BBCLASSEXTEND = "native nativesdk"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=e4742cf92e89040b39486a6219b68067 \
13                    file://src/gettext.h;beginline=1;endline=17;md5=9c05dda2f58d89b850c399cf22e1a00c"
14
15SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/flex-${PV}.tar.gz \
16           file://run-ptest \
17           file://0001-tests-add-a-target-for-building-tests-without-runnin.patch \
18           ${@bb.utils.contains('PTEST_ENABLED', '1', '', 'file://disable-tests.patch', d)} \
19           file://0001-build-AC_USE_SYSTEM_EXTENSIONS-in-configure.ac.patch \
20           file://check-funcs.patch \
21           file://0001-Emit-no-line-directives-if-gen_line_dirs-is-false.patch \
22           "
23
24SRC_URI[md5sum] = "2882e3179748cc9f9c23ec593d6adc8d"
25SRC_URI[sha256sum] = "e87aae032bf07c26f85ac0ed3250998c37621d95f8bd748b31f15b33c45ee995"
26
27GITHUB_BASE_URI = "https://github.com/westes/flex/releases"
28
29# https://github.com/westes/flex/issues/414
30CVE_STATUS[CVE-2019-6293] = "upstream-wontfix: \
31there is stack exhaustion but no bug and it is building the \
32parser, not running it, effectively similar to a compiler ICE. Upstream no plans to address this."
33
34inherit autotools gettext texinfo ptest github-releases
35
36M4 = "${bindir}/m4"
37M4:class-native = "${STAGING_BINDIR_NATIVE}/m4"
38EXTRA_OECONF += "ac_cv_path_M4=${M4} ac_cv_func_reallocarray=no"
39EXTRA_OEMAKE += "m4=${STAGING_BINDIR_NATIVE}/m4"
40
41EXTRA_OEMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', 'FLEX=${STAGING_BINDIR_NATIVE}/flex', '', d)}"
42
43do_install:append:class-native() {
44	create_wrapper ${D}/${bindir}/flex M4=${M4}
45}
46
47do_install:append:class-nativesdk() {
48	create_wrapper ${D}/${bindir}/flex M4=${M4}
49}
50
51PACKAGES =+ "${PN}-libfl"
52
53FILES:${PN}-libfl = "${libdir}/libfl.so.* ${libdir}/libfl_pic.so.*"
54
55RDEPENDS:${PN} += "m4"
56RDEPENDS:${PN}-ptest += "bash gawk make"
57
58do_compile_ptest() {
59	oe_runmake -C ${B}/tests -f ${B}/tests/Makefile top_builddir=${B} INCLUDES=-I${S}/src buildtests
60}
61PTEST_PARALLEL_MAKE = ""
62
63do_install_ptest() {
64	mkdir -p ${D}${PTEST_PATH}/build-aux/
65	cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
66	cp -r ${S}/tests/* ${D}${PTEST_PATH}
67	cp -r ${B}/tests/* ${D}${PTEST_PATH}
68	sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
69	    -e 's|${DEBUG_PREFIX_MAP}||g' \
70	    -e 's:${HOSTTOOLS_DIR}/::g' \
71	    -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
72	    -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \-e 's/^Makefile:/_Makefile:/' \
73	    -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' \
74	    -e 's/^builddir = \(.*\)/builddir = ./' -e 's/^top_builddir = \(.*\)/top_builddir = ./' \
75	    -e 's:${UNINATIVE_LOADER}:${base_bindir}/false:g' \
76	    -i ${D}${PTEST_PATH}/Makefile
77}
78# The uninative loader is different on i386 & x86_64 hosts. Since it is only
79# being replaced with /bin/false anyway, it doesn't need to be part of the task
80# hash
81do_install_ptest[vardepsexclude] += "UNINATIVE_LOADER"
82
83# Not Apache Flex, or Adobe Flex, or IBM Flex.
84CVE_PRODUCT = "flex_project:flex"
85