1SUMMARY = "tool for automating interactive applications according to a script"
2DESCRIPTION = "Expect is a tool for automating interactive applications according to a script. \
3Following the script, Expect knows what can be expected from a program and what \
4the correct response should be. Expect is also useful for testing these same \
5applications. And by adding Tk, you can also wrap interactive applications in \
6X11 GUIs. An interpreted language provides branching and high-level control \
7structures to direct the dialogue. In addition, the user can take control and \
8interact directly when desired, afterward returning control to the script. \
9"
10HOMEPAGE = "http://sourceforge.net/projects/expect/"
11LICENSE = "PD"
12SECTION = "devel"
13
14LIC_FILES_CHKSUM = "file://license.terms;md5=fbf2de7e9102505b1439db06fc36ce5c"
15
16DEPENDS += "tcl"
17RDEPENDS:${PN} = "tcl"
18
19inherit autotools update-alternatives ptest
20
21SRC_URI = "${SOURCEFORGE_MIRROR}/expect/Expect/${PV}/${BPN}${PV}.tar.gz \
22           file://0001-configure.in.patch \
23           file://0002-tcl.m4.patch \
24           file://0001-expect-install-scripts-without-using-the-fixline1-tc.patch \
25           file://0001-Resolve-string-formatting-issues.patch \
26           file://0001-expect-Fix-segfaults-if-Tcl-is-built-with-stubs-and-.patch \
27           file://0001-exp_main_sub.c-Use-PATH_MAX-for-path.patch \
28           file://0001-fixline1-fix-line-1.patch \
29           file://0001-Add-prototype-to-function-definitions.patch \
30           file://run-ptest \
31           "
32SRC_URI[md5sum] = "00fce8de158422f5ccd2666512329bd2"
33SRC_URI[sha256sum] = "49a7da83b0bdd9f46d04a04deec19c7767bb9a323e40c4781f89caf760b92c34"
34
35UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/expect/files/Expect/"
36UPSTREAM_CHECK_REGEX = "/Expect/(?P<pver>(\d+[\.\-_]*)+)/"
37
38S = "${WORKDIR}/${BPN}${PV}"
39
40do_install:append() {
41	install -d ${D}${libdir}
42        install -m 0755 ${D}${libdir}/expect${PV}/libexpect*.so   ${D}${libdir}/
43        install -m 0755 ${S}/fixline1           ${D}${libdir}/expect${PV}/
44        rm ${D}${libdir}/expect${PV}/libexpect*.so
45        sed -e 's|$dir|${libdir}|' -i ${D}${libdir}/expect${PV}/pkgIndex.tcl
46}
47
48do_install_ptest() {
49    install -d ${D}${PTEST_PATH}
50    cp -r ${S}/tests ${D}${PTEST_PATH}
51}
52
53# Apparently the public Tcl headers are only in /usr/include/tcl8.6
54# when building for the target and nativesdk.
55TCL_INCLUDE_PATH = "--with-tclinclude=${STAGING_INCDIR}/tcl8.6"
56TCL_INCLUDE_PATH:class-native = ""
57
58EXTRA_OECONF += "--with-tcl=${STAGING_LIBDIR} \
59                 --enable-shared \
60                 --enable-threads \
61                 --disable-rpath \
62                 ${TCL_INCLUDE_PATH} \
63                "
64EXTRA_OEMAKE_install = " 'SCRIPTS=' "
65
66ALTERNATIVE:${PN}  = "mkpasswd"
67ALTERNATIVE_LINK_NAME[mkpasswd] = "${bindir}/mkpasswd"
68# Use lower priority than busybox's mkpasswd (created when built with CONFIG_CRYPTPW)
69ALTERNATIVE_PRIORITY[mkpasswd] = "40"
70
71FILES:${PN}-dev = "${libdir_native}/expect${PV}/libexpect*.so \
72                   ${includedir}/expect.h \
73                   ${includedir}/expect_tcl.h \
74                   ${includedir}/expect_comm.h \
75                   ${includedir}/tcldbg.h \
76                   ${includedir}/*.h \
77                  "
78
79FILES:${PN} += "${libdir}/libexpect${PV}.so \
80                ${libdir}/expect${PV}/* \
81               "
82
83BBCLASSEXTEND = "native nativesdk"
84