1# dosfstools OE build file
2# Copyright (C) 2004-2006, Advanced Micro Devices, Inc.  All Rights Reserved
3# Copyright (C) 2015, Sören Brinkmann <soeren.brinkmann@gmail>  All Rights Reserved
4# Released under the MIT license (see packages/COPYING)
5SUMMARY = "DOS FAT Filesystem Utilities"
6HOMEPAGE = "https://github.com/dosfstools/dosfstools"
7
8SECTION = "base"
9LICENSE = "GPLv3"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
11
12SRC_URI = "https://github.com/dosfstools/dosfstools/releases/download/v${PV}/${BP}.tar.gz \
13          "
14SRC_URI[sha256sum] = "64926eebf90092dca21b14259a5301b7b98e7b1943e8a201c7d726084809b527"
15
16UPSTREAM_CHECK_URI = "https://github.com/dosfstools/dosfstools/releases"
17
18inherit autotools gettext pkgconfig update-alternatives
19
20EXTRA_OECONF = "--enable-compat-symlinks --without-iconv"
21
22CFLAGS += "-D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
23
24BBCLASSEXTEND = "native nativesdk"
25
26ALTERNATIVE_PRIORITY = "100"
27ALTERNATIVE:${PN} = "mkfs.vfat"
28ALTERNATIVE_LINK_NAME[mkfs.vfat] = "${sbindir}/mkfs.vfat"
29