1SUMMARY = "Tool to edit rpath in ELF binaries"
2DESCRIPTION = "chrpath allows you to change the rpath (where the \
3application looks for libraries) in an application. It does not \
4(yet) allow you to add an rpath if there isn't one already."
5HOMEPAGE = "https://tracker.debian.org/pkg/chrpath"
6LICENSE = "GPL-2.0-only"
7LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
8
9SRC_URI = "${DEBIAN_MIRROR}/main/c/${BPN}/${BPN}_${PV}.orig.tar.gz \
10           file://standarddoc.patch"
11
12SRC_URI[md5sum] = "2bf8d1d1ee345fc8a7915576f5649982"
13SRC_URI[sha256sum] = "bb0d4c54bac2990e1bdf8132f2c9477ae752859d523e141e72b3b11a12c26e7b"
14
15inherit autotools
16
17# We don't have a staged chrpath-native for ensuring our binary is
18# relocatable, so use the one we've just built
19CHRPATH_BIN:class-native = "${B}/chrpath"
20
21PROVIDES:append:class-native = " chrpath-replacement-native"
22NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
23
24BBCLASSEXTEND = "native nativesdk"
25