1# To allow util-linux to optionally build-depend on cryptsetup, libuuid is
2# split out of the main recipe, as it's needed by cryptsetup
3
4require util-linux.inc
5
6inherit autotools gettext pkgconfig
7
8S = "${WORKDIR}/util-linux-${PV}"
9
10EXTRA_AUTORECONF += "--exclude=gtkdocize"
11EXTRA_OECONF += "--disable-all-programs --enable-libuuid"
12
13LICENSE = "BSD-3-Clause"
14
15do_install:append() {
16	rm -rf ${D}${datadir} ${D}${bindir} ${D}${base_bindir} ${D}${sbindir} ${D}${base_sbindir} ${D}${exec_prefix}/sbin
17}
18
19BBCLASSEXTEND = "native nativesdk"
20