1SUMMARY = "Enhances systemd compatilibity with existing SysVinit scripts"
2HOMEPAGE = "http://www.freedesktop.org/wiki/Software/systemd"
3LICENSE = "MIT"
4
5PR = "r29"
6
7PACKAGE_WRITE_DEPS += "systemd-systemctl-native"
8
9S = "${WORKDIR}"
10
11inherit distro_features_check
12
13ALLOW_EMPTY_${PN} = "1"
14
15REQUIRED_DISTRO_FEATURES = "systemd"
16
17SYSTEMD_DISABLED_SYSV_SERVICES = " \
18  busybox-udhcpc \
19  hwclock \
20  networking \
21  nfsserver \
22  nfscommon \
23  syslog.busybox \
24"
25
26pkg_postinst_${PN} () {
27
28	cd $D${sysconfdir}/init.d  ||  exit 0
29
30	echo "Disabling the following sysv scripts: "
31
32	if [ -n "$D" ]; then
33		OPTS="--root=$D"
34	else
35		OPTS=""
36	fi
37
38	for i in ${SYSTEMD_DISABLED_SYSV_SERVICES} ; do
39		if [ -e $i -o -e $i.sh ]  &&   ! [ -e $D${sysconfdir}/systemd/system/$i.service -o -e $D${systemd_unitdir}/system/$i.service ] ; then
40			echo -n "$i: "
41			systemctl $OPTS mask $i.service
42		fi
43	done
44	echo
45}
46
47RDEPENDS_${PN} = "systemd"
48