1DESCRIPTION = "boot image with UEFI shell and tools"
2
3# For this image recipe, only the wic format with a
4# single vfat partition makes sense. Because we have no
5# boot loader and no rootfs partition, not additional
6# tools are needed for this .wks file.
7IMAGE_FSTYPES_forcevariable = 'wic'
8WKS_FILE = "ovmf/ovmf-shell-image.wks"
9WKS_FILE_DEPENDS = ""
10
11inherit image
12
13# We want a minimal image with just ovmf-shell-efi unpacked in it. We
14# avoid installing unnecessary stuff as much as possible, but some
15# things still get through and need to be removed.
16PACKAGE_INSTALL = "ovmf-shell-efi"
17LINGUAS_INSTALL = ""
18do_image () {
19    rm -rf `ls -d ${IMAGE_ROOTFS}/* | grep -v efi`
20}
21