1require newlib.inc
2
3PROVIDES += "virtual/libc virtual/libiconv virtual/libintl"
4
5do_configure() {
6    export CC_FOR_TARGET="${CC}"
7    ${S}/configure ${EXTRA_OECONF}
8}
9
10do_install:append() {
11	# Move include files and libs to default directories so they can be picked up later
12	mv -v ${D}${prefix}/${TARGET_SYS}/lib ${D}${libdir}
13	mv -v ${D}${prefix}/${TARGET_SYS}/include ${D}${includedir}
14
15	# Remove original directory
16	rmdir ${D}${prefix}/${TARGET_SYS}
17}
18
19# No rpm package is actually created but -dev depends on it, avoid dnf error
20DEV_PKG_DEPENDENCY:libc-newlib = ""
21