1SUMMARY = "initramfs-framework module for installation option"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4RDEPENDS_${PN} = "initramfs-framework-base grub parted e2fsprogs-mke2fs util-linux-blkid ${VIRTUAL-RUNTIME_base-utils}"
5RRECOMMENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils-syslog}"
6
7# The same restriction as grub
8COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*)-(linux.*|freebsd.*)'
9COMPATIBLE_HOST_armv7a = 'null'
10COMPATIBLE_HOST_armv7ve = 'null'
11
12PR = "r1"
13
14SRC_URI = "file://init-install.sh"
15
16S = "${WORKDIR}"
17
18do_install() {
19    install -d ${D}/init.d
20    install -m 0755 ${WORKDIR}/init-install.sh ${D}/init.d/install.sh
21}
22
23FILES_${PN} = "/init.d/install.sh"
24