1SUMMARY = "Live image install script for grub"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4SRC_URI = "file://init-install.sh"
5
6PR = "r9"
7
8S = "${WORKDIR}"
9
10RDEPENDS:${PN} = "grub parted e2fsprogs-mke2fs util-linux-blkid ${VIRTUAL-RUNTIME_base-utils}"
11RRECOMMENDS:${PN} = "${VIRTUAL-RUNTIME_base-utils-syslog}"
12
13do_install() {
14        install -m 0755 ${WORKDIR}/init-install.sh ${D}/install.sh
15}
16
17# While this package maybe an allarch due to it being a
18# simple script, reality is that it is Host specific based
19# on the COMPATIBLE_HOST below, which needs to take precedence
20#inherit allarch
21INHIBIT_DEFAULT_DEPS = "1"
22
23FILES:${PN} = " /install.sh "
24
25COMPATIBLE_HOST = "(i.86.*|x86_64.*|aarch64.*)-linux"
26