1SUMMARY = "Live image install script for grub-efi"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4SRC_URI = "file://init-install-efi.sh"
5
6
7RDEPENDS:${PN} = "parted e2fsprogs-mke2fs dosfstools util-linux-blkid ${VIRTUAL-RUNTIME_base-utils}"
8RRECOMMENDS:${PN} = "${VIRTUAL-RUNTIME_base-utils-syslog}"
9
10S = "${WORKDIR}"
11
12do_install() {
13        install -m 0755 ${WORKDIR}/init-install-efi.sh ${D}/install-efi.sh
14}
15
16# While this package maybe an allarch due to it being a
17# simple script, reality is that it is Host specific based
18# on the COMPATIBLE_HOST below, which needs to take precedence
19#inherit allarch
20INHIBIT_DEFAULT_DEPS = "1"
21
22FILES:${PN} = " /install-efi.sh "
23
24COMPATIBLE_HOST = "(i.86.*|x86_64.*|aarch64.*)-linux"
25