1inherit features_check
2REQUIRED_DISTRO_FEATURES = "ptest"
3
4require core-image-minimal.bb
5require conf/distro/include/ptest-packagelists.inc
6
7# Include only fast (< 30 sec) ptests
8IMAGE_INSTALL += "${PTESTS_FAST}"
9
10DESCRIPTION += "Also includes ptest packages with fast execution times to allow for more automated QA."
11HOMEPAGE = "https://www.yoctoproject.org/"
12
13# This image is sufficiently large (~1.8GB) that it can't actually fit in a live
14# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
15# box) and explicitly add just 1500MB.
16# strace-ptest in particular needs more than 500MB
17IMAGE_OVERHEAD_FACTOR = "1.0"
18IMAGE_ROOTFS_EXTRA_SPACE = "1524288"
19
20# ptests need more memory than standard to avoid the OOM killer
21QB_MEM = "-m 1024"
22
23# Sadly at the moment the fast set of ptests is not robust enough and sporadically fails in a couple of places
24PTEST_EXPECT_FAILURE = "1"
25