1# Simple initramfs image. Mostly used for live images.
2SUMMARY = "Small image capable of booting a device."
3DESCRIPTION = "Small image capable of booting a device. The kernel includes \
4the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
5first 'init' program more efficiently."
6
7INITRAMFS_SCRIPTS ?= "\
8                      initramfs-framework-base \
9                      initramfs-module-setup-live \
10                      initramfs-module-udev \
11                      initramfs-module-install \
12                      initramfs-module-install-efi \
13                     "
14
15PACKAGE_INSTALL = "${INITRAMFS_SCRIPTS} ${VIRTUAL-RUNTIME_base-utils} udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
16
17# Do not pollute the initrd image with rootfs features
18IMAGE_FEATURES = ""
19
20export IMAGE_BASENAME = "${MLPREFIX}core-image-minimal-initramfs"
21IMAGE_NAME_SUFFIX ?= ""
22IMAGE_LINGUAS = ""
23
24LICENSE = "MIT"
25
26IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
27inherit core-image
28
29IMAGE_ROOTFS_SIZE = "8192"
30IMAGE_ROOTFS_EXTRA_SPACE = "0"
31
32# Use the same restriction as initramfs-module-install
33COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*|loongarch64.*)-(linux.*|freebsd.*)'
34