1eb8dc403SDave Cobbley# Simple initramfs image. Mostly used for live images.
2eb8dc403SDave CobbleyDESCRIPTION = "Small image capable of booting a device. The kernel includes \
3eb8dc403SDave Cobbleythe Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
4eb8dc403SDave Cobbleyfirst 'init' program more efficiently."
5eb8dc403SDave Cobbley
6eb8dc403SDave CobbleyINITRAMFS_SCRIPTS ?= "\
7eb8dc403SDave Cobbley                      initramfs-framework-base \
8eb8dc403SDave Cobbley                      initramfs-module-setup-live \
9eb8dc403SDave Cobbley                      initramfs-module-udev \
10eb8dc403SDave Cobbley                      initramfs-module-install \
11eb8dc403SDave Cobbley                      initramfs-module-install-efi \
12eb8dc403SDave Cobbley                     "
13eb8dc403SDave Cobbley
14eb8dc403SDave CobbleyPACKAGE_INSTALL = "${INITRAMFS_SCRIPTS} ${VIRTUAL-RUNTIME_base-utils} udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
15eb8dc403SDave Cobbley
16eb8dc403SDave Cobbley# Do not pollute the initrd image with rootfs features
17eb8dc403SDave CobbleyIMAGE_FEATURES = ""
18eb8dc403SDave Cobbley
19eb8dc403SDave Cobbleyexport IMAGE_BASENAME = "${MLPREFIX}core-image-minimal-initramfs"
20c9f7865aSAndrew GeisslerIMAGE_NAME_SUFFIX ?= ""
21eb8dc403SDave CobbleyIMAGE_LINGUAS = ""
22eb8dc403SDave Cobbley
23eb8dc403SDave CobbleyLICENSE = "MIT"
24eb8dc403SDave Cobbley
25eb8dc403SDave CobbleyIMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
26eb8dc403SDave Cobbleyinherit core-image
27eb8dc403SDave Cobbley
28eb8dc403SDave CobbleyIMAGE_ROOTFS_SIZE = "8192"
29eb8dc403SDave CobbleyIMAGE_ROOTFS_EXTRA_SPACE = "0"
30eb8dc403SDave Cobbley
314ed12e16SAndrew Geissler# Use the same restriction as initramfs-module-install
32*b542dec1SPatrick WilliamsCOMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*|loongarch64.*)-(linux.*|freebsd.*)'
33