1SUMMARY = "A standalone native ldconfig build"
2
3LICENSE = "GPLv2+"
4
5LIC_FILES_CHKSUM = "file://${S}/ldconfig.c;endline=17;md5=1d15f20937c055cb5de2329a4c054399"
6
7SRC_URI = "file://ldconfig-native-2.12.1.tar.bz2 \
8           file://ldconfig.patch \
9           file://ldconfig_aux-cache_path_fix.patch \
10           file://32and64bit.patch \
11           file://endian-ness_handling.patch \
12           file://flag_fix.patch \
13           file://endianess-header.patch \
14           file://ldconfig-default-to-all-multilib-dirs.patch \
15           file://endian-ness_handling_fix.patch \
16           file://add-64-bit-flag-for-ELF64-entries.patch \
17           file://no-aux-cache.patch \
18           file://add-riscv-support.patch \
19"
20
21PR = "r2"
22
23FILESEXTRAPATHS =. "${FILE_DIRNAME}/${P}:"
24
25inherit native
26
27S = "${WORKDIR}/${PN}-${PV}"
28
29do_compile () {
30	$CC ldconfig.c -std=gnu99 chroot_canon.c xmalloc.c xstrdup.c cache.c readlib.c  -I. dl-cache.c -o ldconfig
31}
32
33do_install () {
34	install -d ${D}/${bindir}/
35	install ldconfig ${D}/${bindir}/
36}
37