1SUMMARY = "Enables PPP dial-in through a serial connection"
2SECTION = "console/network"
3DESCRIPTION = "PPP dail-in provides a point to point protocol (PPP), so that other computers can dial up to it and access connected networks."
4DEPENDS = "ppp"
5RDEPENDS:${PN} = "ppp"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
8
9SRC_URI = "file://host-peer \
10           file://ppp-dialin"
11
12inherit allarch useradd
13
14S = "${WORKDIR}"
15
16do_install() {
17	install -d ${D}${sysconfdir}/ppp/peers
18	install -m 0644 ${WORKDIR}/host-peer ${D}${sysconfdir}/ppp/peers/host
19
20	install -d ${D}${sbindir}
21	install -m 0755 ${WORKDIR}/ppp-dialin ${D}${sbindir}
22}
23
24USERADD_PACKAGES = "${PN}"
25USERADD_PARAM:${PN} = "--system --home /dev/null \
26                       --no-create-home --shell ${sbindir}/ppp-dialin \
27                       --no-user-group --gid nogroup ppp"
28