1SUMMARY = "Connman config to ignore wired interface on qemu machines"
2DESCRIPTION = "This is the ConnMan configuration to avoid touching wired \
3network interface inside qemu machines."
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
6
7
8SRC_URI = "file://main.conf \
9          "
10
11S = "${WORKDIR}"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15FILES:${PN} = "${sysconfdir}/*"
16
17# Kernel IP-Config is perfectly capable of setting up networking passed in via ip=
18do_install:append:qemuall() {
19    mkdir -p ${D}${sysconfdir}/connman
20    cp ${S}/main.conf ${D}${sysconfdir}/connman/main.conf
21}
22