1SUMMARY = "Connman config to ignore wired interface on qemu machines"
2DESCRIPTION = "This is the ConnMan configuration to avoid touching wired \
3network interface inside qemu machines."
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
6
7PR = "r2"
8
9SRC_URI = "file://main.conf \
10          "
11
12S = "${WORKDIR}"
13
14PACKAGE_ARCH = "${MACHINE_ARCH}"
15
16FILES:${PN} = "${sysconfdir}/*"
17
18# Kernel IP-Config is perfectly capable of setting up networking passed in via ip=
19do_install:append:qemuall() {
20    mkdir -p ${D}${sysconfdir}/connman
21    cp ${S}/main.conf ${D}${sysconfdir}/connman/main.conf
22}
23