1SUMMARY = "Avahi IPv4LL network address configuration daemon"
2DESCRIPTION = 'Avahi is a fully LGPL framework for Multicast DNS Service Discovery. It \
3allows programs to publish and discover services and hosts running on a local network \
4with no specific configuration. This tool implements IPv4LL, "Dynamic Configuration of \
5IPv4 Link-Local Addresses" (IETF RFC3927), a protocol for automatic IP address \
6configuration from the link-local 169.254.0.0/16 range without the need for a central \
7server.'
8AUTHOR = "Lennart Poettering <lennart@poettering.net>"
9HOMEPAGE = "http://avahi.org"
10BUGTRACKER = "https://github.com/lathiat/avahi/issues"
11SECTION = "network"
12
13# major part is under LGPLv2.1+, but several .dtd, .xsl, initscripts and
14# python scripts are under GPLv2+
15LICENSE = "GPLv2+ & LGPLv2.1+"
16LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \
17                    file://avahi-common/address.h;endline=25;md5=b1d1d2cda1c07eb848ea7d6215712d9d \
18                    file://avahi-core/dns.h;endline=23;md5=6fe82590b81aa0ddea5095b548e2fdcb \
19                    file://avahi-daemon/main.c;endline=21;md5=9ee77368c5407af77caaef1b07285969 \
20                    file://avahi-client/client.h;endline=23;md5=f4ac741a25c4f434039ba3e18c8674cf"
21
22SRC_URI = "https://github.com/lathiat/avahi/releases/download/v${PV}/avahi-${PV}.tar.gz \
23           file://00avahi-autoipd \
24           file://99avahi-autoipd \
25           file://initscript.patch \
26           file://0001-Fix-opening-etc-resolv.conf-error.patch \
27           "
28
29UPSTREAM_CHECK_URI = "https://github.com/lathiat/avahi/releases/"
30SRC_URI[md5sum] = "229c6aa30674fc43c202b22c5f8c2be7"
31SRC_URI[sha256sum] = "060309d7a333d38d951bc27598c677af1796934dbd98e1024e7ad8de798fedda"
32
33# Issue only affects Debian/SUSE, not us
34CVE_CHECK_WHITELIST += "CVE-2021-26720"
35
36DEPENDS = "expat libcap libdaemon glib-2.0 intltool-native"
37
38# For gtk related PACKAGECONFIGs: gtk, gtk3
39AVAHI_GTK ?= ""
40
41PACKAGECONFIG ??= "dbus ${@bb.utils.contains_any('DISTRO_FEATURES','x11 wayland','${AVAHI_GTK}','',d)}"
42PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus"
43PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+"
44PACKAGECONFIG[gtk3] = "--enable-gtk3,--disable-gtk3,gtk+3"
45PACKAGECONFIG[libdns_sd] = "--enable-compat-libdns_sd --enable-dbus,,dbus"
46PACKAGECONFIG[libevent] = "--enable-libevent,--disable-libevent,libevent"
47PACKAGECONFIG[qt5] = "--enable-qt5,--disable-qt5,qtbase"
48
49inherit autotools pkgconfig gettext gobject-introspection
50
51EXTRA_OECONF = "--with-avahi-priv-access-group=adm \
52             --disable-stack-protector \
53             --disable-gdbm \
54             --disable-dbm \
55             --disable-mono \
56             --disable-monodoc \
57             --disable-qt3 \
58             --disable-qt4 \
59             --disable-python \
60             --disable-doxygen-doc \
61             --enable-manpages \
62             ${EXTRA_OECONF_SYSVINIT} \
63             ${EXTRA_OECONF_SYSTEMD} \
64           "
65
66# The distro choice determines what init scripts are installed
67EXTRA_OECONF_SYSVINIT = "${@bb.utils.contains('DISTRO_FEATURES','sysvinit','--with-distro=debian','--with-distro=none',d)}"
68EXTRA_OECONF_SYSTEMD = "${@bb.utils.contains('DISTRO_FEATURES','systemd','--with-systemdsystemunitdir=${systemd_unitdir}/system/','--without-systemdsystemunitdir',d)}"
69
70do_configure_prepend() {
71    # This m4 file will get in the way of our introspection.m4 with special cross-compilation fixes
72    rm "${S}/common/introspection.m4" || true
73}
74
75do_compile_prepend() {
76    export GIR_EXTRA_LIBS_PATH="${B}/avahi-gobject/.libs:${B}/avahi-common/.libs:${B}/avahi-client/.libs:${B}/avahi-glib/.libs"
77}
78
79RRECOMMENDS_${PN}_append_libc-glibc = " libnss-mdns"
80
81do_install() {
82	autotools_do_install
83	rm -rf ${D}/run
84	rm -rf ${D}${datadir}/dbus-1/interfaces
85	test -d ${D}${datadir}/dbus-1 && rmdir --ignore-fail-on-non-empty ${D}${datadir}/dbus-1
86	rm -rf ${D}${libdir}/avahi
87
88	# Move example service files out of /etc/avahi/services so we don't
89	# advertise ssh & sftp-ssh by default
90	install -d ${D}${docdir}/avahi
91	mv ${D}${sysconfdir}/avahi/services/* ${D}${docdir}/avahi
92}
93
94PACKAGES =+ "${@bb.utils.contains("PACKAGECONFIG", "libdns_sd", "libavahi-compat-libdnssd", "", d)}"
95
96FILES_libavahi-compat-libdnssd = "${libdir}/libdns_sd.so.*"
97
98RPROVIDES_libavahi-compat-libdnssd = "libdns-sd"
99
100inherit update-rc.d systemd useradd
101
102PACKAGES =+ "libavahi-gobject avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-autoipd avahi-utils avahi-discover avahi-ui"
103
104FILES_avahi-ui = "${libdir}/libavahi-ui*.so.*"
105FILES_avahi-discover = "${datadir}/applications/avahi-discover.desktop \
106                        ${datadir}/avahi/interfaces/avahi-discover.ui \
107                        ${bindir}/avahi-discover-standalone \
108                        "
109
110LICENSE_libavahi-gobject = "LGPLv2.1+"
111LICENSE_avahi-daemon = "LGPLv2.1+"
112LICENSE_libavahi-common = "LGPLv2.1+"
113LICENSE_libavahi-core = "LGPLv2.1+"
114LICENSE_libavahi-client = "LGPLv2.1+"
115LICENSE_avahi-dnsconfd = "LGPLv2.1+"
116LICENSE_libavahi-glib = "LGPLv2.1+"
117LICENSE_avahi-autoipd = "LGPLv2.1+"
118LICENSE_avahi-utils = "LGPLv2.1+"
119
120# As avahi doesn't put any files into PN, clear the files list to avoid problems
121# if extra libraries appear.
122FILES_${PN} = ""
123FILES_avahi-autoipd = "${sbindir}/avahi-autoipd \
124                       ${sysconfdir}/avahi/avahi-autoipd.action \
125                       ${sysconfdir}/dhcp/*/avahi-autoipd \
126                       ${sysconfdir}/udhcpc.d/00avahi-autoipd \
127                       ${sysconfdir}/udhcpc.d/99avahi-autoipd"
128FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
129FILES_libavahi-core = "${libdir}/libavahi-core.so.* ${libdir}/girepository-1.0/AvahiCore*.typelib"
130FILES_avahi-daemon = "${sbindir}/avahi-daemon \
131                      ${sysconfdir}/avahi/avahi-daemon.conf \
132                      ${sysconfdir}/avahi/hosts \
133                      ${sysconfdir}/avahi/services \
134                      ${sysconfdir}/dbus-1 \
135                      ${sysconfdir}/init.d/avahi-daemon \
136                      ${datadir}/avahi/introspection/*.introspect \
137                      ${datadir}/avahi/avahi-service.dtd \
138                      ${datadir}/avahi/service-types \
139                      ${datadir}/dbus-1/system-services"
140FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
141FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
142                        ${sysconfdir}/avahi/avahi-dnsconfd.action \
143                        ${sysconfdir}/init.d/avahi-dnsconfd"
144FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
145FILES_libavahi-gobject = "${libdir}/libavahi-gobject.so.*  ${libdir}/girepository-1.0/Avahi*.typelib"
146FILES_avahi-utils = "${bindir}/avahi-* ${bindir}/b* ${datadir}/applications/b*"
147
148RDEPENDS_${PN}-dev = "avahi-daemon (= ${EXTENDPKGV}) libavahi-core (= ${EXTENDPKGV})"
149RDEPENDS_${PN}-dev += "${@["", " libavahi-client (= ${EXTENDPKGV})"][bb.utils.contains('PACKAGECONFIG', 'dbus', 1, 0, d)]}"
150RDEPENDS_${PN}-dnsconfd = "${PN}-daemon"
151
152RRECOMMENDS_avahi-daemon_append_libc-glibc = " libnss-mdns"
153
154CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
155
156USERADD_PACKAGES = "avahi-daemon avahi-autoipd"
157USERADD_PARAM_avahi-daemon = "--system --home /run/avahi-daemon \
158                              --no-create-home --shell /bin/false \
159                              --user-group avahi"
160
161USERADD_PARAM_avahi-autoipd = "--system --home /run/avahi-autoipd \
162                              --no-create-home --shell /bin/false \
163                              --user-group \
164                              -c \"Avahi autoip daemon\" \
165                              avahi-autoipd"
166
167INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
168INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
169INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
170INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
171INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
172
173SYSTEMD_PACKAGES = "${PN}-daemon ${PN}-dnsconfd"
174SYSTEMD_SERVICE_${PN}-daemon = "avahi-daemon.service"
175SYSTEMD_SERVICE_${PN}-dnsconfd = "avahi-dnsconfd.service"
176
177do_install_append() {
178	install -d ${D}${sysconfdir}/udhcpc.d
179	install ${WORKDIR}/00avahi-autoipd ${D}${sysconfdir}/udhcpc.d
180	install ${WORKDIR}/99avahi-autoipd ${D}${sysconfdir}/udhcpc.d
181}
182
183# At the time the postinst runs, dbus might not be setup so only restart if running
184# Don't exit early, because update-rc.d needs to run subsequently.
185pkg_postinst_avahi-daemon () {
186if [ -z "$D" ]; then
187	killall -q -HUP dbus-daemon || true
188fi
189}
190
191