1SUMMARY = "Avahi IPv4LL network address configuration daemon"
2DESCRIPTION = 'Avahi is a fully LGPL framework for Multicast DNS Service Discovery. It \
3allows programs to publish and discover services and hosts running on a local network \
4with no specific configuration. This tool implements IPv4LL, "Dynamic Configuration of \
5IPv4 Link-Local Addresses" (IETF RFC3927), a protocol for automatic IP address \
6configuration from the link-local 169.254.0.0/16 range without the need for a central \
7server.'
8AUTHOR = "Lennart Poettering <lennart@poettering.net>"
9HOMEPAGE = "http://avahi.org"
10BUGTRACKER = "https://github.com/lathiat/avahi/issues"
11SECTION = "network"
12
13# major part is under LGPL-2.1-or-later, but several .dtd, .xsl, initscripts and
14# python scripts are under GPL-2.0-or-later
15LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
16LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \
17                    file://avahi-common/address.h;endline=25;md5=b1d1d2cda1c07eb848ea7d6215712d9d \
18                    file://avahi-core/dns.h;endline=23;md5=6fe82590b81aa0ddea5095b548e2fdcb \
19                    file://avahi-daemon/main.c;endline=21;md5=9ee77368c5407af77caaef1b07285969 \
20                    file://avahi-client/client.h;endline=23;md5=f4ac741a25c4f434039ba3e18c8674cf"
21
22SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/avahi-${PV}.tar.gz \
23           file://00avahi-autoipd \
24           file://99avahi-autoipd \
25           file://initscript.patch \
26           file://0001-Fix-opening-etc-resolv.conf-error.patch \
27           file://handle-hup.patch \
28           file://local-ping.patch \
29           "
30
31GITHUB_BASE_URI = "https://github.com/lathiat/avahi/releases/"
32SRC_URI[md5sum] = "229c6aa30674fc43c202b22c5f8c2be7"
33SRC_URI[sha256sum] = "060309d7a333d38d951bc27598c677af1796934dbd98e1024e7ad8de798fedda"
34
35CVE_STATUS[CVE-2021-26720] = "not-applicable-platform: Issue only affects Debian/SUSE"
36
37DEPENDS = "expat libcap libdaemon glib-2.0 glib-2.0-native"
38
39# For gtk related PACKAGECONFIGs: gtk, gtk3
40AVAHI_GTK ?= ""
41
42PACKAGECONFIG ??= "dbus ${@bb.utils.contains_any('DISTRO_FEATURES','x11 wayland','${AVAHI_GTK}','',d)}"
43PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus"
44PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+"
45PACKAGECONFIG[gtk3] = "--enable-gtk3,--disable-gtk3,gtk+3"
46PACKAGECONFIG[libdns_sd] = "--enable-compat-libdns_sd --enable-dbus,,dbus"
47PACKAGECONFIG[libevent] = "--enable-libevent,--disable-libevent,libevent"
48PACKAGECONFIG[qt5] = "--enable-qt5,--disable-qt5,qtbase"
49
50inherit autotools pkgconfig gettext gobject-introspection github-releases
51
52EXTRA_OECONF = "--with-avahi-priv-access-group=adm \
53             --disable-stack-protector \
54             --disable-gdbm \
55             --disable-dbm \
56             --disable-mono \
57             --disable-monodoc \
58             --disable-qt3 \
59             --disable-qt4 \
60             --disable-python \
61             --disable-doxygen-doc \
62             --enable-manpages \
63             ${EXTRA_OECONF_SYSVINIT} \
64             ${EXTRA_OECONF_SYSTEMD} \
65           "
66
67# The distro choice determines what init scripts are installed
68EXTRA_OECONF_SYSVINIT = "${@bb.utils.contains('DISTRO_FEATURES','sysvinit','--with-distro=debian','--with-distro=none',d)}"
69EXTRA_OECONF_SYSTEMD = "${@bb.utils.contains('DISTRO_FEATURES','systemd','--with-systemdsystemunitdir=${systemd_system_unitdir}/','--without-systemdsystemunitdir',d)}"
70
71do_configure:prepend() {
72    # This m4 file will get in the way of our introspection.m4 with special cross-compilation fixes
73    rm "${S}/common/introspection.m4" || true
74}
75
76do_compile:prepend() {
77    export GIR_EXTRA_LIBS_PATH="${B}/avahi-gobject/.libs:${B}/avahi-common/.libs:${B}/avahi-client/.libs:${B}/avahi-glib/.libs"
78}
79
80RRECOMMENDS:${PN}:append:libc-glibc = " libnss-mdns"
81
82do_install() {
83	autotools_do_install
84	rm -rf ${D}/run
85	test -d ${D}${datadir}/dbus-1 && rmdir --ignore-fail-on-non-empty ${D}${datadir}/dbus-1
86	rm -rf ${D}${libdir}/avahi
87
88	# Move example service files out of /etc/avahi/services so we don't
89	# advertise ssh & sftp-ssh by default
90	install -d ${D}${docdir}/avahi
91	mv ${D}${sysconfdir}/avahi/services/* ${D}${docdir}/avahi
92}
93
94PACKAGES =+ "${@bb.utils.contains("PACKAGECONFIG", "libdns_sd", "libavahi-compat-libdnssd", "", d)}"
95
96FILES:libavahi-compat-libdnssd = "${libdir}/libdns_sd.so.*"
97
98RPROVIDES:libavahi-compat-libdnssd = "libdns-sd"
99
100inherit update-rc.d systemd useradd
101
102PACKAGES =+ "libavahi-gobject avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-autoipd avahi-utils avahi-discover avahi-ui"
103
104FILES:avahi-ui = "${libdir}/libavahi-ui*.so.*"
105FILES:avahi-discover = "${datadir}/applications/avahi-discover.desktop \
106                        ${datadir}/avahi/interfaces/avahi-discover.ui \
107                        ${bindir}/avahi-discover-standalone \
108                        "
109
110LICENSE:libavahi-gobject = "LGPL-2.1-or-later"
111LICENSE:avahi-daemon = "LGPL-2.1-or-later"
112LICENSE:libavahi-common = "LGPL-2.1-or-later"
113LICENSE:libavahi-core = "LGPL-2.1-or-later"
114LICENSE:libavahi-client = "LGPL-2.1-or-later"
115LICENSE:avahi-dnsconfd = "LGPL-2.1-or-later"
116LICENSE:libavahi-glib = "LGPL-2.1-or-later"
117LICENSE:avahi-autoipd = "LGPL-2.1-or-later"
118LICENSE:avahi-utils = "LGPL-2.1-or-later"
119
120# As avahi doesn't put any files into PN, clear the files list to avoid problems
121# if extra libraries appear.
122FILES:${PN} = ""
123FILES:avahi-autoipd = "${sbindir}/avahi-autoipd \
124                       ${sysconfdir}/avahi/avahi-autoipd.action \
125                       ${sysconfdir}/dhcp/*/avahi-autoipd \
126                       ${sysconfdir}/udhcpc.d/00avahi-autoipd \
127                       ${sysconfdir}/udhcpc.d/99avahi-autoipd"
128FILES:libavahi-common = "${libdir}/libavahi-common.so.*"
129FILES:libavahi-core = "${libdir}/libavahi-core.so.* ${libdir}/girepository-1.0/AvahiCore*.typelib"
130FILES:avahi-daemon = "${sbindir}/avahi-daemon \
131                      ${sysconfdir}/avahi/avahi-daemon.conf \
132                      ${sysconfdir}/avahi/hosts \
133                      ${sysconfdir}/avahi/services \
134                      ${sysconfdir}/dbus-1 \
135                      ${sysconfdir}/init.d/avahi-daemon \
136                      ${datadir}/dbus-1/interfaces \
137                      ${datadir}/avahi/avahi-service.dtd \
138                      ${datadir}/avahi/service-types \
139                      ${datadir}/dbus-1/system-services"
140FILES:libavahi-client = "${libdir}/libavahi-client.so.*"
141FILES:avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
142                        ${sysconfdir}/avahi/avahi-dnsconfd.action \
143                        ${sysconfdir}/init.d/avahi-dnsconfd"
144FILES:libavahi-glib = "${libdir}/libavahi-glib.so.*"
145FILES:libavahi-gobject = "${libdir}/libavahi-gobject.so.*  ${libdir}/girepository-1.0/Avahi*.typelib"
146FILES:avahi-utils = "${bindir}/avahi-* ${bindir}/b* ${datadir}/applications/b*"
147
148DEV_PKG_DEPENDENCY = "avahi-daemon (= ${EXTENDPKGV}) libavahi-core (= ${EXTENDPKGV})"
149DEV_PKG_DEPENDENCY += "${@["", " libavahi-client (= ${EXTENDPKGV})"][bb.utils.contains('PACKAGECONFIG', 'dbus', 1, 0, d)]}"
150RDEPENDS:${PN}-dnsconfd = "${PN}-daemon"
151
152RRECOMMENDS:avahi-daemon:append:libc-glibc = " libnss-mdns"
153
154CONFFILES:avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
155
156USERADD_PACKAGES = "avahi-daemon avahi-autoipd"
157USERADD_PARAM:avahi-daemon = "--system --home /run/avahi-daemon \
158                              --no-create-home --shell /bin/false \
159                              --user-group avahi"
160
161USERADD_PARAM:avahi-autoipd = "--system --home /run/avahi-autoipd \
162                              --no-create-home --shell /bin/false \
163                              --user-group \
164                              -c \"Avahi autoip daemon\" \
165                              avahi-autoipd"
166
167INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
168INITSCRIPT_NAME:avahi-daemon = "avahi-daemon"
169INITSCRIPT_PARAMS:avahi-daemon = "defaults 21 19"
170INITSCRIPT_NAME:avahi-dnsconfd = "avahi-dnsconfd"
171INITSCRIPT_PARAMS:avahi-dnsconfd = "defaults 22 19"
172
173SYSTEMD_PACKAGES = "${PN}-daemon ${PN}-dnsconfd"
174SYSTEMD_SERVICE:${PN}-daemon = "avahi-daemon.service"
175SYSTEMD_SERVICE:${PN}-dnsconfd = "avahi-dnsconfd.service"
176
177do_install:append() {
178	install -d ${D}${sysconfdir}/udhcpc.d
179	install ${WORKDIR}/00avahi-autoipd ${D}${sysconfdir}/udhcpc.d
180	install ${WORKDIR}/99avahi-autoipd ${D}${sysconfdir}/udhcpc.d
181}
182
183# At the time the postinst runs, dbus might not be setup so only restart if running
184# Don't exit early, because update-rc.d needs to run subsequently.
185pkg_postinst:avahi-daemon () {
186if [ -z "$D" ]; then
187	killall -q -HUP dbus-daemon || true
188fi
189}
190
191