1SUMMARY = "User support binary for the uvesafb kernel module"
2HOMEPAGE = "https://tracker.debian.org/pkg/v86d"
3DESCRIPTION = "v86d provides a backend for kernel drivers that need to execute x86 BIOS code. The code is executed in a controlled environment and the results are passed back to the kernel via the netlink interface."
4
5# the copyright info is at the bottom of README, expect break
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://README;md5=94ac1971e4f2309dc322d598e7b1f7dd"
8
9DEPENDS = "virtual/kernel"
10RRECOMMENDS_${PN} = "kernel-module-uvesafb"
11PR = "r2"
12
13SRC_URI = "http://snapshot.debian.org/archive/debian/20110427T035506Z/pool/main/v/${BPN}/${BPN}_${PV}.orig.tar.gz \
14           file://Update-x86emu-from-X.org.patch \
15           file://ar-from-env.patch \
16           file://Support-for-cross-compilation.patch \
17"
18
19SRC_URI[md5sum] = "889686ec8424468fe0d205742e77a4c2"
20SRC_URI[sha256sum] = "93575c82e4307d8c4c370ec6b767f5cf87e527b2378146d652a6d8e25d5bdbc5"
21
22PACKAGE_ARCH = "${MACHINE_ARCH}"
23COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
24
25do_configure () {
26	TARGET_ARCH="${TARGET_ARCH}" ./configure --with-x86emu
27}
28
29do_compile () {
30	KDIR="${STAGING_DIR_HOST}/usr" make
31}
32
33do_install () {
34	install -d ${D}${base_sbindir}
35	install v86d ${D}${base_sbindir}/
36}
37