1SUMMARY = "Initscript for enabling USB gadget Ethernet"
2DESCRIPTION = "This module allows ethernet emulation over USB, allowing for \
3all sorts of nifty things like SSH and NFS in one go plus charging over the \
4same wire, at higher speeds than most Wifi connections."
5HOMEPAGE = "http://linux-sunxi.org/USB_Gadget/Ethernet"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
9
10PR = "r3"
11
12SRC_URI = "file://usb-gether \
13           file://COPYING.GPL"
14S = "${WORKDIR}"
15
16do_install() {
17    install -d ${D}${sysconfdir}
18    install -d ${D}${sysconfdir}/init.d
19    install usb-gether ${D}${sysconfdir}/init.d
20}
21
22inherit update-rc.d allarch
23
24INITSCRIPT_NAME = "usb-gether"
25INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
26