1SUMMARY = "Controls the configuration of serial ports"
2DESCRIPTION = "setserial is a program designed to set and/or report the configuration information associated with a serial port"
3HOMEPAGE = "http://setserial.sourceforge.net"
4SECTION = "console/utils"
5
6LICENSE = "GPL-2.0-only"
7LIC_FILES_CHKSUM = "file://version.h;beginline=1;endline=6;md5=2e7c59cb9e57e356ae81f50f4e4dfd99"
8PR = "r3"
9
10DEPENDS += "groff-native"
11
12inherit autotools-brokensep
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/setserial/${BPN}-${PV}.tar.gz \
15           file://add_stdlib.patch \
16           file://ldflags.patch \
17           file://0001-setserial.c-Add-needed-system-headers-for-ioctl-and-.patch \
18           "
19
20SRC_URI[md5sum] = "c4867d72c41564318e0107745eb7a0f2"
21SRC_URI[sha256sum] = "7e4487d320ac31558563424189435d396ddf77953bb23111a17a3d1487b5794a"
22
23do_install() {
24    install -d ${D}${bindir}
25    install -d ${D}${mandir}/man8
26
27    install -m 0755 ${S}/setserial   ${D}${bindir}
28    install -m 0644 ${S}/setserial.8 ${D}${mandir}/man8
29}
30