1#
2# Collects debug information in order to create error report files.
3#
4# Copyright (C) 2013 Intel Corporation
5# Author: Andreea Brandusa Proca <andreea.b.proca@intel.com>
6#
7# Licensed under the MIT license, see COPYING.MIT for details
8
9ERR_REPORT_DIR ?= "${LOG_DIR}/error-report"
10
11def errorreport_getdata(e):
12    import codecs
13    logpath = e.data.getVar('ERR_REPORT_DIR')
14    datafile = os.path.join(logpath, "error-report.txt")
15    with codecs.open(datafile, 'r', 'utf-8') as f:
16        data = f.read()
17    return data
18
19def errorreport_savedata(e, newdata, file):
20    import json
21    import codecs
22    logpath = e.data.getVar('ERR_REPORT_DIR')
23    datafile = os.path.join(logpath, file)
24    with codecs.open(datafile, 'w', 'utf-8') as f:
25        json.dump(newdata, f, indent=4, sort_keys=True)
26    return datafile
27
28def get_conf_data(e, filename):
29    builddir = e.data.getVar('TOPDIR')
30    filepath = os.path.join(builddir, "conf", filename)
31    jsonstring = ""
32    if os.path.exists(filepath):
33        with open(filepath, 'r') as f:
34            for line in f.readlines():
35                if line.startswith("#") or len(line.strip()) == 0:
36                    continue
37                else:
38                    jsonstring=jsonstring + line
39    return jsonstring
40
41python errorreport_handler () {
42        import json
43        import codecs
44
45        def nativelsb():
46            nativelsbstr = e.data.getVar("NATIVELSBSTRING")
47            # provide a bit more host info in case of uninative build
48            if e.data.getVar('UNINATIVE_URL') != 'unset':
49                return '/'.join([nativelsbstr, lsb_distro_identifier(e.data)])
50            return nativelsbstr
51
52        logpath = e.data.getVar('ERR_REPORT_DIR')
53        datafile = os.path.join(logpath, "error-report.txt")
54
55        if isinstance(e, bb.event.BuildStarted):
56            bb.utils.mkdirhier(logpath)
57            data = {}
58            machine = e.data.getVar("MACHINE")
59            data['machine'] = machine
60            data['build_sys'] = e.data.getVar("BUILD_SYS")
61            data['nativelsb'] = nativelsb()
62            data['distro'] = e.data.getVar("DISTRO")
63            data['target_sys'] = e.data.getVar("TARGET_SYS")
64            data['failures'] = []
65            data['component'] = " ".join(e.getPkgs())
66            data['branch_commit'] = str(base_detect_branch(e.data)) + ": " + str(base_detect_revision(e.data))
67            data['local_conf'] = get_conf_data(e, 'local.conf')
68            data['auto_conf'] = get_conf_data(e, 'auto.conf')
69            lock = bb.utils.lockfile(datafile + '.lock')
70            errorreport_savedata(e, data, "error-report.txt")
71            bb.utils.unlockfile(lock)
72
73        elif isinstance(e, bb.build.TaskFailed):
74            task = e.task
75            taskdata={}
76            log = e.data.getVar('BB_LOGFILE')
77            taskdata['package'] = e.data.expand("${PF}")
78            taskdata['task'] = task
79            if log:
80                try:
81                    logFile = codecs.open(log, 'r', 'utf-8')
82                    logdata = logFile.read()
83
84                    # Replace host-specific paths so the logs are cleaner
85                    for d in ("TOPDIR", "TMPDIR"):
86                        s = e.data.getVar(d)
87                        if s:
88                            logdata = logdata.replace(s, d)
89
90                    logFile.close()
91                except:
92                    logdata = "Unable to read log file"
93
94            else:
95                logdata = "No Log"
96
97            # server will refuse failures longer than param specified in project.settings.py
98            # MAX_UPLOAD_SIZE = "5242880"
99            # use lower value, because 650 chars can be spent in task, package, version
100            max_logdata_size = 5242000
101            # upload last max_logdata_size characters
102            if len(logdata) > max_logdata_size:
103                logdata = "..." + logdata[-max_logdata_size:]
104            taskdata['log'] = logdata
105            lock = bb.utils.lockfile(datafile + '.lock')
106            jsondata = json.loads(errorreport_getdata(e))
107            jsondata['failures'].append(taskdata)
108            errorreport_savedata(e, jsondata, "error-report.txt")
109            bb.utils.unlockfile(lock)
110
111        elif isinstance(e, bb.event.BuildCompleted):
112            lock = bb.utils.lockfile(datafile + '.lock')
113            jsondata = json.loads(errorreport_getdata(e))
114            bb.utils.unlockfile(lock)
115            failures = jsondata['failures']
116            if(len(failures) > 0):
117                filename = "error_report_" + e.data.getVar("BUILDNAME")+".txt"
118                datafile = errorreport_savedata(e, jsondata, filename)
119                bb.note("The errors for this build are stored in %s\nYou can send the errors to a reports server by running:\n  send-error-report %s [-s server]" % (datafile, datafile))
120                bb.note("The contents of these logs will be posted in public if you use the above command with the default server. Please ensure you remove any identifying or proprietary information when prompted before sending.")
121}
122
123addhandler errorreport_handler
124errorreport_handler[eventmask] = "bb.event.BuildStarted bb.event.BuildCompleted bb.build.TaskFailed"
125