1#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7# This class is used to check recipes against public CVEs.
8#
9# In order to use this class just inherit the class in the
10# local.conf file and it will add the cve_check task for
11# every recipe. The task can be used per recipe, per image,
12# or using the special cases "world" and "universe". The
13# cve_check task will print a warning for every unpatched
14# CVE found and generate a file in the recipe WORKDIR/cve
15# directory. If an image is build it will generate a report
16# in DEPLOY_DIR_IMAGE for all the packages used.
17#
18# Example:
19#   bitbake -c cve_check openssl
20#   bitbake core-image-sato
21#   bitbake -k -c cve_check universe
22#
23# DISCLAIMER
24#
25# This class/tool is meant to be used as support and not
26# the only method to check against CVEs. Running this tool
27# doesn't guarantee your packages are free of CVEs.
28
29# The product name that the CVE database uses defaults to BPN, but may need to
30# be overriden per recipe (for example tiff.bb sets CVE_PRODUCT=libtiff).
31CVE_PRODUCT ??= "${BPN}"
32CVE_VERSION ??= "${PV}"
33
34CVE_CHECK_DB_DIR ?= "${DL_DIR}/CVE_CHECK"
35CVE_CHECK_DB_FILE ?= "${CVE_CHECK_DB_DIR}/nvdcve_2.db"
36CVE_CHECK_DB_FILE_LOCK ?= "${CVE_CHECK_DB_FILE}.lock"
37
38CVE_CHECK_LOG ?= "${T}/cve.log"
39CVE_CHECK_TMP_FILE ?= "${TMPDIR}/cve_check"
40CVE_CHECK_SUMMARY_DIR ?= "${LOG_DIR}/cve"
41CVE_CHECK_SUMMARY_FILE_NAME ?= "cve-summary"
42CVE_CHECK_SUMMARY_FILE ?= "${CVE_CHECK_SUMMARY_DIR}/${CVE_CHECK_SUMMARY_FILE_NAME}"
43CVE_CHECK_SUMMARY_FILE_NAME_JSON = "cve-summary.json"
44CVE_CHECK_SUMMARY_INDEX_PATH = "${CVE_CHECK_SUMMARY_DIR}/cve-summary-index.txt"
45
46CVE_CHECK_LOG_JSON ?= "${T}/cve.json"
47
48CVE_CHECK_DIR ??= "${DEPLOY_DIR}/cve"
49CVE_CHECK_RECIPE_FILE ?= "${CVE_CHECK_DIR}/${PN}"
50CVE_CHECK_RECIPE_FILE_JSON ?= "${CVE_CHECK_DIR}/${PN}_cve.json"
51CVE_CHECK_MANIFEST ?= "${IMGDEPLOYDIR}/${IMAGE_NAME}.cve"
52CVE_CHECK_MANIFEST_JSON ?= "${IMGDEPLOYDIR}/${IMAGE_NAME}.json"
53CVE_CHECK_COPY_FILES ??= "1"
54CVE_CHECK_CREATE_MANIFEST ??= "1"
55
56# Report Patched or Ignored CVEs
57CVE_CHECK_REPORT_PATCHED ??= "1"
58
59CVE_CHECK_SHOW_WARNINGS ??= "1"
60
61# Provide text output
62CVE_CHECK_FORMAT_TEXT ??= "1"
63
64# Provide JSON output
65CVE_CHECK_FORMAT_JSON ??= "1"
66
67# Check for packages without CVEs (no issues or missing product name)
68CVE_CHECK_COVERAGE ??= "1"
69
70# Skip CVE Check for packages (PN)
71CVE_CHECK_SKIP_RECIPE ?= ""
72
73# Replace NVD DB check status for a given CVE. Each of CVE has to be mentioned
74# separately with optional detail and description for this status.
75#
76# CVE_STATUS[CVE-1234-0001] = "not-applicable-platform: Issue only applies on Windows"
77# CVE_STATUS[CVE-1234-0002] = "fixed-version: Fixed externally"
78#
79# Settings the same status and reason for multiple CVEs is possible
80# via CVE_STATUS_GROUPS variable.
81#
82# CVE_STATUS_GROUPS = "CVE_STATUS_WIN CVE_STATUS_PATCHED"
83#
84# CVE_STATUS_WIN = "CVE-1234-0001 CVE-1234-0003"
85# CVE_STATUS_WIN[status] = "not-applicable-platform: Issue only applies on Windows"
86# CVE_STATUS_PATCHED = "CVE-1234-0002 CVE-1234-0004"
87# CVE_STATUS_PATCHED[status] = "fixed-version: Fixed externally"
88#
89# All possible CVE statuses could be found in cve-check-map.conf
90# CVE_CHECK_STATUSMAP[not-applicable-platform] = "Ignored"
91# CVE_CHECK_STATUSMAP[fixed-version] = "Patched"
92#
93# CVE_CHECK_IGNORE is deprecated and CVE_STATUS has to be used instead.
94# Keep CVE_CHECK_IGNORE until other layers migrate to new variables
95CVE_CHECK_IGNORE ?= ""
96
97# Layers to be excluded
98CVE_CHECK_LAYER_EXCLUDELIST ??= ""
99
100# Layers to be included
101CVE_CHECK_LAYER_INCLUDELIST ??= ""
102
103
104# set to "alphabetical" for version using single alphabetical character as increment release
105CVE_VERSION_SUFFIX ??= ""
106
107python () {
108    # Fallback all CVEs from CVE_CHECK_IGNORE to CVE_STATUS
109    cve_check_ignore = d.getVar("CVE_CHECK_IGNORE")
110    if cve_check_ignore:
111        bb.warn("CVE_CHECK_IGNORE is deprecated in favor of CVE_STATUS")
112        for cve in (d.getVar("CVE_CHECK_IGNORE") or "").split():
113            d.setVarFlag("CVE_STATUS", cve, "ignored")
114
115    # Process CVE_STATUS_GROUPS to set multiple statuses and optional detail or description at once
116    for cve_status_group in (d.getVar("CVE_STATUS_GROUPS") or "").split():
117        cve_group = d.getVar(cve_status_group)
118        if cve_group is not None:
119            for cve in cve_group.split():
120                d.setVarFlag("CVE_STATUS", cve, d.getVarFlag(cve_status_group, "status"))
121        else:
122            bb.warn("CVE_STATUS_GROUPS contains undefined variable %s" % cve_status_group)
123}
124
125def generate_json_report(d, out_path, link_path):
126    if os.path.exists(d.getVar("CVE_CHECK_SUMMARY_INDEX_PATH")):
127        import json
128        from oe.cve_check import cve_check_merge_jsons, update_symlinks
129
130        bb.note("Generating JSON CVE summary")
131        index_file = d.getVar("CVE_CHECK_SUMMARY_INDEX_PATH")
132        summary = {"version":"1", "package": []}
133        with open(index_file) as f:
134            filename = f.readline()
135            while filename:
136                with open(filename.rstrip()) as j:
137                    data = json.load(j)
138                    cve_check_merge_jsons(summary, data)
139                filename = f.readline()
140
141        with open(out_path, "w") as f:
142            json.dump(summary, f, indent=2)
143
144        update_symlinks(out_path, link_path)
145
146python cve_save_summary_handler () {
147    import shutil
148    import datetime
149    from oe.cve_check import update_symlinks
150
151    cve_tmp_file = d.getVar("CVE_CHECK_TMP_FILE")
152
153    cve_summary_name = d.getVar("CVE_CHECK_SUMMARY_FILE_NAME")
154    cvelogpath = d.getVar("CVE_CHECK_SUMMARY_DIR")
155    bb.utils.mkdirhier(cvelogpath)
156
157    timestamp = datetime.datetime.now().strftime('%Y%m%d%H%M%S')
158    cve_summary_file = os.path.join(cvelogpath, "%s-%s.txt" % (cve_summary_name, timestamp))
159
160    if os.path.exists(cve_tmp_file):
161        shutil.copyfile(cve_tmp_file, cve_summary_file)
162        cvefile_link = os.path.join(cvelogpath, cve_summary_name)
163        update_symlinks(cve_summary_file, cvefile_link)
164        bb.plain("Complete CVE report summary created at: %s" % cvefile_link)
165
166    if d.getVar("CVE_CHECK_FORMAT_JSON") == "1":
167        json_summary_link_name = os.path.join(cvelogpath, d.getVar("CVE_CHECK_SUMMARY_FILE_NAME_JSON"))
168        json_summary_name = os.path.join(cvelogpath, "%s-%s.json" % (cve_summary_name, timestamp))
169        generate_json_report(d, json_summary_name, json_summary_link_name)
170        bb.plain("Complete CVE JSON report summary created at: %s" % json_summary_link_name)
171}
172
173addhandler cve_save_summary_handler
174cve_save_summary_handler[eventmask] = "bb.event.BuildCompleted"
175
176python do_cve_check () {
177    """
178    Check recipe for patched and unpatched CVEs
179    """
180    from oe.cve_check import get_patched_cves
181
182    with bb.utils.fileslocked([d.getVar("CVE_CHECK_DB_FILE_LOCK")], shared=True):
183        if os.path.exists(d.getVar("CVE_CHECK_DB_FILE")):
184            try:
185                patched_cves = get_patched_cves(d)
186            except FileNotFoundError:
187                bb.fatal("Failure in searching patches")
188            ignored, patched, unpatched, status = check_cves(d, patched_cves)
189            if patched or unpatched or (d.getVar("CVE_CHECK_COVERAGE") == "1" and status):
190                cve_data = get_cve_info(d, patched + unpatched + ignored)
191                cve_write_data(d, patched, unpatched, ignored, cve_data, status)
192        else:
193            bb.note("No CVE database found, skipping CVE check")
194
195}
196
197addtask cve_check before do_build
198do_cve_check[depends] = "cve-update-nvd2-native:do_fetch"
199do_cve_check[nostamp] = "1"
200
201python cve_check_cleanup () {
202    """
203    Delete the file used to gather all the CVE information.
204    """
205    bb.utils.remove(e.data.getVar("CVE_CHECK_TMP_FILE"))
206    bb.utils.remove(e.data.getVar("CVE_CHECK_SUMMARY_INDEX_PATH"))
207}
208
209addhandler cve_check_cleanup
210cve_check_cleanup[eventmask] = "bb.event.BuildCompleted"
211
212python cve_check_write_rootfs_manifest () {
213    """
214    Create CVE manifest when building an image
215    """
216
217    import shutil
218    import json
219    from oe.rootfs import image_list_installed_packages
220    from oe.cve_check import cve_check_merge_jsons, update_symlinks
221
222    if d.getVar("CVE_CHECK_COPY_FILES") == "1":
223        deploy_file = d.getVar("CVE_CHECK_RECIPE_FILE")
224        if os.path.exists(deploy_file):
225            bb.utils.remove(deploy_file)
226        deploy_file_json = d.getVar("CVE_CHECK_RECIPE_FILE_JSON")
227        if os.path.exists(deploy_file_json):
228            bb.utils.remove(deploy_file_json)
229
230    # Create a list of relevant recipies
231    recipies = set()
232    for pkg in list(image_list_installed_packages(d)):
233        pkg_info = os.path.join(d.getVar('PKGDATA_DIR'),
234                                'runtime-reverse', pkg)
235        pkg_data = oe.packagedata.read_pkgdatafile(pkg_info)
236        recipies.add(pkg_data["PN"])
237
238    bb.note("Writing rootfs CVE manifest")
239    deploy_dir = d.getVar("IMGDEPLOYDIR")
240    link_name = d.getVar("IMAGE_LINK_NAME")
241
242    json_data = {"version":"1", "package": []}
243    text_data = ""
244    enable_json = d.getVar("CVE_CHECK_FORMAT_JSON") == "1"
245    enable_text = d.getVar("CVE_CHECK_FORMAT_TEXT") == "1"
246
247    save_pn = d.getVar("PN")
248
249    for pkg in recipies:
250        # To be able to use the CVE_CHECK_RECIPE_FILE variable we have to evaluate
251        # it with the different PN names set each time.
252        d.setVar("PN", pkg)
253        if enable_text:
254            pkgfilepath = d.getVar("CVE_CHECK_RECIPE_FILE")
255            if os.path.exists(pkgfilepath):
256                with open(pkgfilepath) as pfile:
257                    text_data += pfile.read()
258
259        if enable_json:
260            pkgfilepath = d.getVar("CVE_CHECK_RECIPE_FILE_JSON")
261            if os.path.exists(pkgfilepath):
262                with open(pkgfilepath) as j:
263                    data = json.load(j)
264                    cve_check_merge_jsons(json_data, data)
265
266    d.setVar("PN", save_pn)
267
268    if enable_text:
269        link_path = os.path.join(deploy_dir, "%s.cve" % link_name)
270        manifest_name = d.getVar("CVE_CHECK_MANIFEST")
271
272        with open(manifest_name, "w") as f:
273            f.write(text_data)
274
275        update_symlinks(manifest_name, link_path)
276        bb.plain("Image CVE report stored in: %s" % manifest_name)
277
278    if enable_json:
279        link_path = os.path.join(deploy_dir, "%s.json" % link_name)
280        manifest_name = d.getVar("CVE_CHECK_MANIFEST_JSON")
281
282        with open(manifest_name, "w") as f:
283            json.dump(json_data, f, indent=2)
284
285        update_symlinks(manifest_name, link_path)
286        bb.plain("Image CVE JSON report stored in: %s" % manifest_name)
287}
288
289ROOTFS_POSTPROCESS_COMMAND:prepend = "${@'cve_check_write_rootfs_manifest; ' if d.getVar('CVE_CHECK_CREATE_MANIFEST') == '1' else ''}"
290do_rootfs[recrdeptask] += "${@'do_cve_check' if d.getVar('CVE_CHECK_CREATE_MANIFEST') == '1' else ''}"
291do_populate_sdk[recrdeptask] += "${@'do_cve_check' if d.getVar('CVE_CHECK_CREATE_MANIFEST') == '1' else ''}"
292
293def check_cves(d, patched_cves):
294    """
295    Connect to the NVD database and find unpatched cves.
296    """
297    from oe.cve_check import Version, convert_cve_version, decode_cve_status
298
299    pn = d.getVar("PN")
300    real_pv = d.getVar("PV")
301    suffix = d.getVar("CVE_VERSION_SUFFIX")
302
303    cves_unpatched = []
304    cves_ignored = []
305    cves_status = []
306    cves_in_recipe = False
307    # CVE_PRODUCT can contain more than one product (eg. curl/libcurl)
308    products = d.getVar("CVE_PRODUCT").split()
309    # If this has been unset then we're not scanning for CVEs here (for example, image recipes)
310    if not products:
311        return ([], [], [], [])
312    pv = d.getVar("CVE_VERSION").split("+git")[0]
313
314    # If the recipe has been skipped/ignored we return empty lists
315    if pn in d.getVar("CVE_CHECK_SKIP_RECIPE").split():
316        bb.note("Recipe has been skipped by cve-check")
317        return ([], [], [], [])
318
319    # Convert CVE_STATUS into ignored CVEs and check validity
320    cve_ignore = []
321    for cve in (d.getVarFlags("CVE_STATUS") or {}):
322        decoded_status, _, _ = decode_cve_status(d, cve)
323        if decoded_status == "Ignored":
324            cve_ignore.append(cve)
325
326    import sqlite3
327    db_file = d.expand("file:${CVE_CHECK_DB_FILE}?mode=ro")
328    conn = sqlite3.connect(db_file, uri=True)
329
330    # For each of the known product names (e.g. curl has CPEs using curl and libcurl)...
331    for product in products:
332        cves_in_product = False
333        if ":" in product:
334            vendor, product = product.split(":", 1)
335        else:
336            vendor = "%"
337
338        # Find all relevant CVE IDs.
339        cve_cursor = conn.execute("SELECT DISTINCT ID FROM PRODUCTS WHERE PRODUCT IS ? AND VENDOR LIKE ?", (product, vendor))
340        for cverow in cve_cursor:
341            cve = cverow[0]
342
343            if cve in cve_ignore:
344                bb.note("%s-%s ignores %s" % (product, pv, cve))
345                cves_ignored.append(cve)
346                continue
347            elif cve in patched_cves:
348                bb.note("%s has been patched" % (cve))
349                continue
350            # Write status once only for each product
351            if not cves_in_product:
352                cves_status.append([product, True])
353                cves_in_product = True
354                cves_in_recipe = True
355
356            vulnerable = False
357            ignored = False
358
359            product_cursor = conn.execute("SELECT * FROM PRODUCTS WHERE ID IS ? AND PRODUCT IS ? AND VENDOR LIKE ?", (cve, product, vendor))
360            for row in product_cursor:
361                (_, _, _, version_start, operator_start, version_end, operator_end) = row
362                #bb.debug(2, "Evaluating row " + str(row))
363                if cve in cve_ignore:
364                    ignored = True
365
366                version_start = convert_cve_version(version_start)
367                version_end = convert_cve_version(version_end)
368
369                if (operator_start == '=' and pv == version_start) or version_start == '-':
370                    vulnerable = True
371                else:
372                    if operator_start:
373                        try:
374                            vulnerable_start =  (operator_start == '>=' and Version(pv,suffix) >= Version(version_start,suffix))
375                            vulnerable_start |= (operator_start == '>' and Version(pv,suffix) > Version(version_start,suffix))
376                        except:
377                            bb.warn("%s: Failed to compare %s %s %s for %s" %
378                                    (product, pv, operator_start, version_start, cve))
379                            vulnerable_start = False
380                    else:
381                        vulnerable_start = False
382
383                    if operator_end:
384                        try:
385                            vulnerable_end  = (operator_end == '<=' and Version(pv,suffix) <= Version(version_end,suffix) )
386                            vulnerable_end |= (operator_end == '<' and Version(pv,suffix) < Version(version_end,suffix) )
387                        except:
388                            bb.warn("%s: Failed to compare %s %s %s for %s" %
389                                    (product, pv, operator_end, version_end, cve))
390                            vulnerable_end = False
391                    else:
392                        vulnerable_end = False
393
394                    if operator_start and operator_end:
395                        vulnerable = vulnerable_start and vulnerable_end
396                    else:
397                        vulnerable = vulnerable_start or vulnerable_end
398
399                if vulnerable:
400                    if ignored:
401                        bb.note("%s is ignored in %s-%s" % (cve, pn, real_pv))
402                        cves_ignored.append(cve)
403                    else:
404                        bb.note("%s-%s is vulnerable to %s" % (pn, real_pv, cve))
405                        cves_unpatched.append(cve)
406                    break
407            product_cursor.close()
408
409            if not vulnerable:
410                bb.note("%s-%s is not vulnerable to %s" % (pn, real_pv, cve))
411                patched_cves.add(cve)
412        cve_cursor.close()
413
414        if not cves_in_product:
415            bb.note("No CVE records found for product %s, pn %s" % (product, pn))
416            cves_status.append([product, False])
417
418    conn.close()
419
420    if not cves_in_recipe:
421        bb.note("No CVE records for products in recipe %s" % (pn))
422
423    return (list(cves_ignored), list(patched_cves), cves_unpatched, cves_status)
424
425def get_cve_info(d, cves):
426    """
427    Get CVE information from the database.
428    """
429
430    import sqlite3
431
432    cve_data = {}
433    db_file = d.expand("file:${CVE_CHECK_DB_FILE}?mode=ro")
434    conn = sqlite3.connect(db_file, uri=True)
435
436    for cve in cves:
437        cursor = conn.execute("SELECT * FROM NVD WHERE ID IS ?", (cve,))
438        for row in cursor:
439            cve_data[row[0]] = {}
440            cve_data[row[0]]["summary"] = row[1]
441            cve_data[row[0]]["scorev2"] = row[2]
442            cve_data[row[0]]["scorev3"] = row[3]
443            cve_data[row[0]]["modified"] = row[4]
444            cve_data[row[0]]["vector"] = row[5]
445        cursor.close()
446    conn.close()
447    return cve_data
448
449def cve_write_data_text(d, patched, unpatched, ignored, cve_data):
450    """
451    Write CVE information in WORKDIR; and to CVE_CHECK_DIR, and
452    CVE manifest if enabled.
453    """
454
455    from oe.cve_check import decode_cve_status
456
457    cve_file = d.getVar("CVE_CHECK_LOG")
458    fdir_name  = d.getVar("FILE_DIRNAME")
459    layer = fdir_name.split("/")[-3]
460
461    include_layers = d.getVar("CVE_CHECK_LAYER_INCLUDELIST").split()
462    exclude_layers = d.getVar("CVE_CHECK_LAYER_EXCLUDELIST").split()
463
464    report_all = d.getVar("CVE_CHECK_REPORT_PATCHED") == "1"
465
466    if exclude_layers and layer in exclude_layers:
467        return
468
469    if include_layers and layer not in include_layers:
470        return
471
472    # Early exit, the text format does not report packages without CVEs
473    if not patched+unpatched+ignored:
474        return
475
476    nvd_link = "https://nvd.nist.gov/vuln/detail/"
477    write_string = ""
478    unpatched_cves = []
479    bb.utils.mkdirhier(os.path.dirname(cve_file))
480
481    for cve in sorted(cve_data):
482        is_patched = cve in patched
483        is_ignored = cve in ignored
484
485        status = "Unpatched"
486        if (is_patched or is_ignored) and not report_all:
487            continue
488        if is_ignored:
489            status = "Ignored"
490        elif is_patched:
491            status = "Patched"
492        else:
493            # default value of status is Unpatched
494            unpatched_cves.append(cve)
495
496        write_string += "LAYER: %s\n" % layer
497        write_string += "PACKAGE NAME: %s\n" % d.getVar("PN")
498        write_string += "PACKAGE VERSION: %s%s\n" % (d.getVar("EXTENDPE"), d.getVar("PV"))
499        write_string += "CVE: %s\n" % cve
500        write_string += "CVE STATUS: %s\n" % status
501        _, detail, description = decode_cve_status(d, cve)
502        if detail:
503            write_string += "CVE DETAIL: %s\n" % detail
504        if description:
505            write_string += "CVE DESCRIPTION: %s\n" % description
506        write_string += "CVE SUMMARY: %s\n" % cve_data[cve]["summary"]
507        write_string += "CVSS v2 BASE SCORE: %s\n" % cve_data[cve]["scorev2"]
508        write_string += "CVSS v3 BASE SCORE: %s\n" % cve_data[cve]["scorev3"]
509        write_string += "VECTOR: %s\n" % cve_data[cve]["vector"]
510        write_string += "MORE INFORMATION: %s%s\n\n" % (nvd_link, cve)
511
512    if unpatched_cves and d.getVar("CVE_CHECK_SHOW_WARNINGS") == "1":
513        bb.warn("Found unpatched CVE (%s), for more information check %s" % (" ".join(unpatched_cves),cve_file))
514
515    with open(cve_file, "w") as f:
516        bb.note("Writing file %s with CVE information" % cve_file)
517        f.write(write_string)
518
519    if d.getVar("CVE_CHECK_COPY_FILES") == "1":
520        deploy_file = d.getVar("CVE_CHECK_RECIPE_FILE")
521        bb.utils.mkdirhier(os.path.dirname(deploy_file))
522        with open(deploy_file, "w") as f:
523            f.write(write_string)
524
525    if d.getVar("CVE_CHECK_CREATE_MANIFEST") == "1":
526        cvelogpath = d.getVar("CVE_CHECK_SUMMARY_DIR")
527        bb.utils.mkdirhier(cvelogpath)
528
529        with open(d.getVar("CVE_CHECK_TMP_FILE"), "a") as f:
530            f.write("%s" % write_string)
531
532def cve_check_write_json_output(d, output, direct_file, deploy_file, manifest_file):
533    """
534    Write CVE information in the JSON format: to WORKDIR; and to
535    CVE_CHECK_DIR, if CVE manifest if enabled, write fragment
536    files that will be assembled at the end in cve_check_write_rootfs_manifest.
537    """
538
539    import json
540
541    write_string = json.dumps(output, indent=2)
542    with open(direct_file, "w") as f:
543        bb.note("Writing file %s with CVE information" % direct_file)
544        f.write(write_string)
545
546    if d.getVar("CVE_CHECK_COPY_FILES") == "1":
547        bb.utils.mkdirhier(os.path.dirname(deploy_file))
548        with open(deploy_file, "w") as f:
549            f.write(write_string)
550
551    if d.getVar("CVE_CHECK_CREATE_MANIFEST") == "1":
552        cvelogpath = d.getVar("CVE_CHECK_SUMMARY_DIR")
553        index_path = d.getVar("CVE_CHECK_SUMMARY_INDEX_PATH")
554        bb.utils.mkdirhier(cvelogpath)
555        fragment_file = os.path.basename(deploy_file)
556        fragment_path = os.path.join(cvelogpath, fragment_file)
557        with open(fragment_path, "w") as f:
558            f.write(write_string)
559        with open(index_path, "a+") as f:
560            f.write("%s\n" % fragment_path)
561
562def cve_write_data_json(d, patched, unpatched, ignored, cve_data, cve_status):
563    """
564    Prepare CVE data for the JSON format, then write it.
565    """
566
567    from oe.cve_check import decode_cve_status
568
569    output = {"version":"1", "package": []}
570    nvd_link = "https://nvd.nist.gov/vuln/detail/"
571
572    fdir_name  = d.getVar("FILE_DIRNAME")
573    layer = fdir_name.split("/")[-3]
574
575    include_layers = d.getVar("CVE_CHECK_LAYER_INCLUDELIST").split()
576    exclude_layers = d.getVar("CVE_CHECK_LAYER_EXCLUDELIST").split()
577
578    report_all = d.getVar("CVE_CHECK_REPORT_PATCHED") == "1"
579
580    if exclude_layers and layer in exclude_layers:
581        return
582
583    if include_layers and layer not in include_layers:
584        return
585
586    unpatched_cves = []
587
588    product_data = []
589    for s in cve_status:
590        p = {"product": s[0], "cvesInRecord": "Yes"}
591        if s[1] == False:
592            p["cvesInRecord"] = "No"
593        product_data.append(p)
594
595    package_version = "%s%s" % (d.getVar("EXTENDPE"), d.getVar("PV"))
596    package_data = {
597        "name" : d.getVar("PN"),
598        "layer" : layer,
599        "version" : package_version,
600        "products": product_data
601    }
602    cve_list = []
603
604    for cve in sorted(cve_data):
605        is_patched = cve in patched
606        is_ignored = cve in ignored
607        status = "Unpatched"
608        if (is_patched or is_ignored) and not report_all:
609            continue
610        if is_ignored:
611            status = "Ignored"
612        elif is_patched:
613            status = "Patched"
614        else:
615            # default value of status is Unpatched
616            unpatched_cves.append(cve)
617
618        issue_link = "%s%s" % (nvd_link, cve)
619
620        cve_item = {
621            "id" : cve,
622            "summary" : cve_data[cve]["summary"],
623            "scorev2" : cve_data[cve]["scorev2"],
624            "scorev3" : cve_data[cve]["scorev3"],
625            "vector" : cve_data[cve]["vector"],
626            "status" : status,
627            "link": issue_link
628        }
629        _, detail, description = decode_cve_status(d, cve)
630        if detail:
631            cve_item["detail"] = detail
632        if description:
633            cve_item["description"] = description
634        cve_list.append(cve_item)
635
636    package_data["issue"] = cve_list
637    output["package"].append(package_data)
638
639    direct_file = d.getVar("CVE_CHECK_LOG_JSON")
640    deploy_file = d.getVar("CVE_CHECK_RECIPE_FILE_JSON")
641    manifest_file = d.getVar("CVE_CHECK_SUMMARY_FILE_NAME_JSON")
642
643    cve_check_write_json_output(d, output, direct_file, deploy_file, manifest_file)
644
645def cve_write_data(d, patched, unpatched, ignored, cve_data, status):
646    """
647    Write CVE data in each enabled format.
648    """
649
650    if d.getVar("CVE_CHECK_FORMAT_TEXT") == "1":
651        cve_write_data_text(d, patched, unpatched, ignored, cve_data)
652    if d.getVar("CVE_CHECK_FORMAT_JSON") == "1":
653        cve_write_data_json(d, patched, unpatched, ignored, cve_data, status)
654