1# This class is used to check recipes against public CVEs.
2#
3# In order to use this class just inherit the class in the
4# local.conf file and it will add the cve_check task for
5# every recipe. The task can be used per recipe, per image,
6# or using the special cases "world" and "universe". The
7# cve_check task will print a warning for every unpatched
8# CVE found and generate a file in the recipe WORKDIR/cve
9# directory. If an image is build it will generate a report
10# in DEPLOY_DIR_IMAGE for all the packages used.
11#
12# Example:
13#   bitbake -c cve_check openssl
14#   bitbake core-image-sato
15#   bitbake -k -c cve_check universe
16#
17# DISCLAIMER
18#
19# This class/tool is meant to be used as support and not
20# the only method to check against CVEs. Running this tool
21# doesn't guarantee your packages are free of CVEs.
22
23# The product name that the CVE database uses.  Defaults to BPN, but may need to
24# be overriden per recipe (for example tiff.bb sets CVE_PRODUCT=libtiff).
25CVE_PRODUCT ??= "${BPN}"
26CVE_VERSION ??= "${PV}"
27
28CVE_CHECK_DB_DIR ?= "${DL_DIR}/CVE_CHECK"
29CVE_CHECK_DB_FILE ?= "${CVE_CHECK_DB_DIR}/nvd.db"
30
31CVE_CHECK_LOG ?= "${T}/cve.log"
32CVE_CHECK_TMP_FILE ?= "${TMPDIR}/cve_check"
33
34CVE_CHECK_DIR ??= "${DEPLOY_DIR}/cve"
35CVE_CHECK_MANIFEST ?= "${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.cve"
36CVE_CHECK_COPY_FILES ??= "1"
37CVE_CHECK_CREATE_MANIFEST ??= "1"
38
39# Whitelist for packages (PN)
40CVE_CHECK_PN_WHITELIST = "\
41    glibc-locale \
42"
43
44# Whitelist for CVE and version of package
45CVE_CHECK_CVE_WHITELIST = "{\
46    'CVE-2014-2524': ('6.3','5.2',), \
47}"
48
49python do_cve_check () {
50    """
51    Check recipe for patched and unpatched CVEs
52    """
53
54    if os.path.exists(d.getVar("CVE_CHECK_TMP_FILE")):
55        patched_cves = get_patches_cves(d)
56        patched, unpatched = check_cves(d, patched_cves)
57        if patched or unpatched:
58            cve_data = get_cve_info(d, patched + unpatched)
59            cve_write_data(d, patched, unpatched, cve_data)
60    else:
61        bb.note("Failed to update CVE database, skipping CVE check")
62}
63
64addtask cve_check after do_unpack before do_build
65do_cve_check[depends] = "cve-check-tool-native:do_populate_sysroot cve-check-tool-native:do_populate_cve_db"
66do_cve_check[nostamp] = "1"
67
68python cve_check_cleanup () {
69    """
70    Delete the file used to gather all the CVE information.
71    """
72
73    bb.utils.remove(e.data.getVar("CVE_CHECK_TMP_FILE"))
74}
75
76addhandler cve_check_cleanup
77cve_check_cleanup[eventmask] = "bb.cooker.CookerExit"
78
79python cve_check_write_rootfs_manifest () {
80    """
81    Create CVE manifest when building an image
82    """
83
84    import shutil
85
86    if d.getVar("CVE_CHECK_COPY_FILES") == "1":
87        deploy_file = os.path.join(d.getVar("CVE_CHECK_DIR"), d.getVar("PN"))
88        if os.path.exists(deploy_file):
89            bb.utils.remove(deploy_file)
90
91    if os.path.exists(d.getVar("CVE_CHECK_TMP_FILE")):
92        bb.note("Writing rootfs CVE manifest")
93        deploy_dir = d.getVar("DEPLOY_DIR_IMAGE")
94        link_name = d.getVar("IMAGE_LINK_NAME")
95        manifest_name = d.getVar("CVE_CHECK_MANIFEST")
96        cve_tmp_file = d.getVar("CVE_CHECK_TMP_FILE")
97
98        shutil.copyfile(cve_tmp_file, manifest_name)
99
100        if manifest_name and os.path.exists(manifest_name):
101            manifest_link = os.path.join(deploy_dir, "%s.cve" % link_name)
102            # If we already have another manifest, update symlinks
103            if os.path.exists(os.path.realpath(manifest_link)):
104                os.remove(manifest_link)
105            os.symlink(os.path.basename(manifest_name), manifest_link)
106            bb.plain("Image CVE report stored in: %s" % manifest_name)
107}
108
109ROOTFS_POSTPROCESS_COMMAND_prepend = "${@'cve_check_write_rootfs_manifest; ' if d.getVar('CVE_CHECK_CREATE_MANIFEST') == '1' else ''}"
110do_rootfs[recrdeptask] += "${@'do_cve_check' if d.getVar('CVE_CHECK_CREATE_MANIFEST') == '1' else ''}"
111
112def get_patches_cves(d):
113    """
114    Get patches that solve CVEs using the "CVE: " tag.
115    """
116
117    import re
118
119    pn = d.getVar("PN")
120    cve_match = re.compile("CVE:( CVE\-\d{4}\-\d+)+")
121
122    # Matches last CVE-1234-211432 in the file name, also if written
123    # with small letters. Not supporting multiple CVE id's in a single
124    # file name.
125    cve_file_name_match = re.compile(".*([Cc][Vv][Ee]\-\d{4}\-\d+)")
126
127    patched_cves = set()
128    bb.debug(2, "Looking for patches that solves CVEs for %s" % pn)
129    for url in src_patches(d):
130        patch_file = bb.fetch.decodeurl(url)[2]
131
132        # Check patch file name for CVE ID
133        fname_match = cve_file_name_match.search(patch_file)
134        if fname_match:
135            cve = fname_match.group(1).upper()
136            patched_cves.add(cve)
137            bb.debug(2, "Found CVE %s from patch file name %s" % (cve, patch_file))
138
139        with open(patch_file, "r", encoding="utf-8") as f:
140            try:
141                patch_text = f.read()
142            except UnicodeDecodeError:
143                bb.debug(1, "Failed to read patch %s using UTF-8 encoding"
144                        " trying with iso8859-1" %  patch_file)
145                f.close()
146                with open(patch_file, "r", encoding="iso8859-1") as f:
147                    patch_text = f.read()
148
149        # Search for one or more "CVE: " lines
150        text_match = False
151        for match in cve_match.finditer(patch_text):
152            # Get only the CVEs without the "CVE: " tag
153            cves = patch_text[match.start()+5:match.end()]
154            for cve in cves.split():
155                bb.debug(2, "Patch %s solves %s" % (patch_file, cve))
156                patched_cves.add(cve)
157                text_match = True
158
159        if not fname_match and not text_match:
160            bb.debug(2, "Patch %s doesn't solve CVEs" % patch_file)
161
162    return patched_cves
163
164def check_cves(d, patched_cves):
165    """
166    Run cve-check-tool looking for patched and unpatched CVEs.
167    """
168
169    import ast, csv, tempfile, subprocess, io
170
171    cves_patched = []
172    cves_unpatched = []
173    bpn = d.getVar("CVE_PRODUCT")
174    # If this has been unset then we're not scanning for CVEs here (for example, image recipes)
175    if not bpn:
176        return ([], [])
177    pv = d.getVar("CVE_VERSION").split("+git")[0]
178    cves = " ".join(patched_cves)
179    cve_db_dir = d.getVar("CVE_CHECK_DB_DIR")
180    cve_whitelist = ast.literal_eval(d.getVar("CVE_CHECK_CVE_WHITELIST"))
181    cve_cmd = "cve-check-tool"
182    cmd = [cve_cmd, "--no-html", "--skip-update", "--csv", "--not-affected", "-t", "faux", "-d", cve_db_dir]
183
184    # If the recipe has been whitlisted we return empty lists
185    if d.getVar("PN") in d.getVar("CVE_CHECK_PN_WHITELIST").split():
186        bb.note("Recipe has been whitelisted, skipping check")
187        return ([], [])
188
189    try:
190        # Write the faux CSV file to be used with cve-check-tool
191        fd, faux = tempfile.mkstemp(prefix="cve-faux-")
192        with os.fdopen(fd, "w") as f:
193            for pn in bpn.split():
194                f.write("%s,%s,%s,\n" % (pn, pv, cves))
195        cmd.append(faux)
196
197        output = subprocess.check_output(cmd).decode("utf-8")
198        bb.debug(2, "Output of command %s:\n%s" % ("\n".join(cmd), output))
199    except subprocess.CalledProcessError as e:
200        bb.warn("Couldn't check for CVEs: %s (output %s)" % (e, e.output))
201    finally:
202        os.remove(faux)
203
204    for row in csv.reader(io.StringIO(output)):
205        # Third row has the unpatched CVEs
206        if row[2]:
207            for cve in row[2].split():
208                # Skip if the CVE has been whitlisted for the current version
209                if pv in cve_whitelist.get(cve,[]):
210                    bb.note("%s-%s has been whitelisted for %s" % (bpn, pv, cve))
211                else:
212                    cves_unpatched.append(cve)
213                    bb.debug(2, "%s-%s is not patched for %s" % (bpn, pv, cve))
214        # Fourth row has patched CVEs
215        if row[3]:
216            for cve in row[3].split():
217                cves_patched.append(cve)
218                bb.debug(2, "%s-%s is patched for %s" % (bpn, pv, cve))
219
220    return (cves_patched, cves_unpatched)
221
222def get_cve_info(d, cves):
223    """
224    Get CVE information from the database used by cve-check-tool.
225
226    Unfortunately the only way to get CVE info is set the output to
227    html (hard to parse) or query directly the database.
228    """
229
230    try:
231        import sqlite3
232    except ImportError:
233        from pysqlite2 import dbapi2 as sqlite3
234
235    cve_data = {}
236    db_file = d.getVar("CVE_CHECK_DB_FILE")
237    placeholder = ",".join("?" * len(cves))
238    query = "SELECT * FROM NVD WHERE id IN (%s)" % placeholder
239    conn = sqlite3.connect(db_file)
240    cur = conn.cursor()
241    for row in cur.execute(query, tuple(cves)):
242        cve_data[row[0]] = {}
243        cve_data[row[0]]["summary"] = row[1]
244        cve_data[row[0]]["score"] = row[2]
245        cve_data[row[0]]["modified"] = row[3]
246        cve_data[row[0]]["vector"] = row[4]
247    conn.close()
248
249    return cve_data
250
251def cve_write_data(d, patched, unpatched, cve_data):
252    """
253    Write CVE information in WORKDIR; and to CVE_CHECK_DIR, and
254    CVE manifest if enabled.
255    """
256
257    cve_file = d.getVar("CVE_CHECK_LOG")
258    nvd_link = "https://web.nvd.nist.gov/view/vuln/detail?vulnId="
259    write_string = ""
260    unpatched_cves = []
261    bb.utils.mkdirhier(os.path.dirname(cve_file))
262
263    for cve in sorted(cve_data):
264        write_string += "PACKAGE NAME: %s\n" % d.getVar("PN")
265        write_string += "PACKAGE VERSION: %s\n" % d.getVar("PV")
266        write_string += "CVE: %s\n" % cve
267        if cve in patched:
268            write_string += "CVE STATUS: Patched\n"
269        else:
270            unpatched_cves.append(cve)
271            write_string += "CVE STATUS: Unpatched\n"
272        write_string += "CVE SUMMARY: %s\n" % cve_data[cve]["summary"]
273        write_string += "CVSS v2 BASE SCORE: %s\n" % cve_data[cve]["score"]
274        write_string += "VECTOR: %s\n" % cve_data[cve]["vector"]
275        write_string += "MORE INFORMATION: %s%s\n\n" % (nvd_link, cve)
276
277    if unpatched_cves:
278        bb.warn("Found unpatched CVE (%s), for more information check %s" % (" ".join(unpatched_cves),cve_file))
279
280    with open(cve_file, "w") as f:
281        bb.note("Writing file %s with CVE information" % cve_file)
282        f.write(write_string)
283
284    if d.getVar("CVE_CHECK_COPY_FILES") == "1":
285        cve_dir = d.getVar("CVE_CHECK_DIR")
286        bb.utils.mkdirhier(cve_dir)
287        deploy_file = os.path.join(cve_dir, d.getVar("PN"))
288        with open(deploy_file, "w") as f:
289            f.write(write_string)
290
291    if d.getVar("CVE_CHECK_CREATE_MANIFEST") == "1":
292        with open(d.getVar("CVE_CHECK_TMP_FILE"), "a") as f:
293            f.write("%s" % write_string)
294