1# ex:ts=4:sw=4:sts=4:et
2# -*- tab-width: 4; c-basic-offset: 4; indent-tabs-mode: nil -*-
3#
4# This bbclass is used for creating archive for:
5#  1) original (or unpacked) source: ARCHIVER_MODE[src] = "original"
6#  2) patched source: ARCHIVER_MODE[src] = "patched" (default)
7#  3) configured source: ARCHIVER_MODE[src] = "configured"
8#  4) source mirror: ARCHIVER_MODE[src] = "mirror"
9#  5) The patches between do_unpack and do_patch:
10#     ARCHIVER_MODE[diff] = "1"
11#     And you can set the one that you'd like to exclude from the diff:
12#     ARCHIVER_MODE[diff-exclude] ?= ".pc autom4te.cache patches"
13#  6) The environment data, similar to 'bitbake -e recipe':
14#     ARCHIVER_MODE[dumpdata] = "1"
15#  7) The recipe (.bb and .inc): ARCHIVER_MODE[recipe] = "1"
16#  8) Whether output the .src.rpm package:
17#     ARCHIVER_MODE[srpm] = "1"
18#  9) Filter the license, the recipe whose license in
19#     COPYLEFT_LICENSE_INCLUDE will be included, and in
20#     COPYLEFT_LICENSE_EXCLUDE will be excluded.
21#     COPYLEFT_LICENSE_INCLUDE = 'GPL* LGPL*'
22#     COPYLEFT_LICENSE_EXCLUDE = 'CLOSED Proprietary'
23# 10) The recipe type that will be archived:
24#     COPYLEFT_RECIPE_TYPES = 'target'
25# 11) The source mirror mode:
26#     ARCHIVER_MODE[mirror] = "split" (default): Sources are split into
27#     per-recipe directories in a similar way to other archiver modes.
28#     Post-processing may be required to produce a single mirror directory.
29#     This does however allow inspection of duplicate sources and more
30#     intelligent handling.
31#     ARCHIVER_MODE[mirror] = "combined": All sources are placed into a single
32#     directory suitable for direct use as a mirror. Duplicate sources are
33#     ignored.
34# 12) Source mirror exclusions:
35#     ARCHIVER_MIRROR_EXCLUDE is a list of prefixes to exclude from the mirror.
36#     This may be used for sources which you are already publishing yourself
37#     (e.g. if the URI starts with 'https://mysite.com/' and your mirror is
38#     going to be published to the same site). It may also be used to exclude
39#     local files (with the prefix 'file://') if these will be provided as part
40#     of an archive of the layers themselves.
41#
42
43# Create archive for all the recipe types
44COPYLEFT_RECIPE_TYPES ?= 'target native nativesdk cross crosssdk cross-canadian'
45inherit copyleft_filter
46
47ARCHIVER_MODE[srpm] ?= "0"
48ARCHIVER_MODE[src] ?= "patched"
49ARCHIVER_MODE[diff] ?= "0"
50ARCHIVER_MODE[diff-exclude] ?= ".pc autom4te.cache patches"
51ARCHIVER_MODE[dumpdata] ?= "0"
52ARCHIVER_MODE[recipe] ?= "0"
53ARCHIVER_MODE[mirror] ?= "split"
54ARCHIVER_MODE[compression] ?= "xz"
55
56DEPLOY_DIR_SRC ?= "${DEPLOY_DIR}/sources"
57ARCHIVER_TOPDIR ?= "${WORKDIR}/archiver-sources"
58ARCHIVER_ARCH = "${TARGET_SYS}"
59ARCHIVER_OUTDIR = "${ARCHIVER_TOPDIR}/${ARCHIVER_ARCH}/${PF}/"
60ARCHIVER_RPMTOPDIR ?= "${WORKDIR}/deploy-sources-rpm"
61ARCHIVER_RPMOUTDIR = "${ARCHIVER_RPMTOPDIR}/${ARCHIVER_ARCH}/${PF}/"
62ARCHIVER_WORKDIR = "${WORKDIR}/archiver-work/"
63
64# When producing a combined mirror directory, allow duplicates for the case
65# where multiple recipes use the same SRC_URI.
66ARCHIVER_COMBINED_MIRRORDIR = "${ARCHIVER_TOPDIR}/mirror"
67SSTATE_ALLOW_OVERLAP_FILES += "${DEPLOY_DIR_SRC}/mirror"
68
69do_dumpdata[dirs] = "${ARCHIVER_OUTDIR}"
70do_ar_recipe[dirs] = "${ARCHIVER_OUTDIR}"
71do_ar_original[dirs] = "${ARCHIVER_OUTDIR} ${ARCHIVER_WORKDIR}"
72do_deploy_archives[dirs] = "${WORKDIR}"
73
74# This is a convenience for the shell script to use it
75
76
77python () {
78    pn = d.getVar('PN')
79    assume_provided = (d.getVar("ASSUME_PROVIDED") or "").split()
80    if pn in assume_provided:
81        for p in d.getVar("PROVIDES").split():
82            if p != pn:
83                pn = p
84                break
85
86    included, reason = copyleft_should_include(d)
87    if not included:
88        bb.debug(1, 'archiver: %s is excluded: %s' % (pn, reason))
89        return
90    else:
91        bb.debug(1, 'archiver: %s is included: %s' % (pn, reason))
92
93
94    # glibc-locale: do_fetch, do_unpack and do_patch tasks have been deleted,
95    # so avoid archiving source here.
96    if pn.startswith('glibc-locale'):
97        return
98
99    # We just archive gcc-source for all the gcc related recipes
100    if d.getVar('BPN') in ['gcc', 'libgcc'] \
101            and not pn.startswith('gcc-source'):
102        bb.debug(1, 'archiver: %s is excluded, covered by gcc-source' % pn)
103        return
104
105    # TARGET_SYS in ARCHIVER_ARCH will break the stamp for gcc-source in multiconfig
106    if pn.startswith('gcc-source'):
107        d.setVar('ARCHIVER_ARCH', "allarch")
108
109    def hasTask(task):
110        return bool(d.getVarFlag(task, "task", False)) and not bool(d.getVarFlag(task, "noexec", False))
111
112    ar_src = d.getVarFlag('ARCHIVER_MODE', 'src')
113    ar_dumpdata = d.getVarFlag('ARCHIVER_MODE', 'dumpdata')
114    ar_recipe = d.getVarFlag('ARCHIVER_MODE', 'recipe')
115
116    if ar_src == "original":
117        d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_original' % pn)
118        # 'patched' and 'configured' invoke do_unpack_and_patch because
119        # do_ar_patched resp. do_ar_configured depend on it, but for 'original'
120        # we have to add it explicitly.
121        if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1':
122            d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_unpack_and_patch' % pn)
123    elif ar_src == "patched":
124        d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_patched' % pn)
125    elif ar_src == "configured":
126        # We can't use "addtask do_ar_configured after do_configure" since it
127        # will cause the deptask of do_populate_sysroot to run no matter what
128        # archives we need, so we add the depends here.
129
130        # There is a corner case with "gcc-source-${PV}" recipes, they don't have
131        # the "do_configure" task, so we need to use "do_preconfigure"
132        if hasTask("do_preconfigure"):
133            d.appendVarFlag('do_ar_configured', 'depends', ' %s:do_preconfigure' % pn)
134        elif hasTask("do_configure"):
135            d.appendVarFlag('do_ar_configured', 'depends', ' %s:do_configure' % pn)
136        d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_configured' % pn)
137    elif ar_src == "mirror":
138        d.appendVarFlag('do_deploy_archives', 'depends', '%s:do_ar_mirror' % pn)
139
140    elif ar_src:
141        bb.fatal("Invalid ARCHIVER_MODE[src]: %s" % ar_src)
142
143    if ar_dumpdata == "1":
144        d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_dumpdata' % pn)
145
146    if ar_recipe == "1":
147        d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_recipe' % pn)
148
149    # Output the SRPM package
150    if d.getVarFlag('ARCHIVER_MODE', 'srpm') == "1" and d.getVar('PACKAGES'):
151        if "package_rpm" not in d.getVar('PACKAGE_CLASSES'):
152            bb.fatal("ARCHIVER_MODE[srpm] needs package_rpm in PACKAGE_CLASSES")
153
154        # Some recipes do not have any packaging tasks
155        if hasTask("do_package_write_rpm"):
156            d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_package_write_rpm' % pn)
157            d.appendVarFlag('do_package_write_rpm', 'dirs', ' ${ARCHIVER_RPMTOPDIR}')
158            d.appendVarFlag('do_package_write_rpm', 'sstate-inputdirs', ' ${ARCHIVER_RPMTOPDIR}')
159            d.appendVarFlag('do_package_write_rpm', 'sstate-outputdirs', ' ${DEPLOY_DIR_SRC}')
160            if ar_dumpdata == "1":
161                d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_dumpdata' % pn)
162            if ar_recipe == "1":
163                d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_recipe' % pn)
164            if ar_src == "original":
165                d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_original' % pn)
166            elif ar_src == "patched":
167                d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_patched' % pn)
168            elif ar_src == "configured":
169                d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_configured' % pn)
170}
171
172# Take all the sources for a recipe and put them in WORKDIR/archiver-work/.
173# Files in SRC_URI are copied directly, anything that's a directory
174# (e.g. git repositories) is "unpacked" and then put into a tarball.
175python do_ar_original() {
176
177    import shutil, tempfile
178
179    if d.getVarFlag('ARCHIVER_MODE', 'src') != "original":
180        return
181
182    ar_outdir = d.getVar('ARCHIVER_OUTDIR')
183    bb.note('Archiving the original source...')
184    urls = d.getVar("SRC_URI").split()
185    # destsuffix (git fetcher) and subdir (everything else) are allowed to be
186    # absolute paths (for example, destsuffix=${S}/foobar).
187    # That messes with unpacking inside our tmpdir below, because the fetchers
188    # will then unpack in that directory and completely ignore the tmpdir.
189    # That breaks parallel tasks relying on ${S}, like do_compile.
190    #
191    # To solve this, we remove these parameters from all URLs.
192    # We do this even for relative paths because it makes the content of the
193    # archives more useful (no extra paths that are only used during
194    # compilation).
195    for i, url in enumerate(urls):
196        decoded = bb.fetch2.decodeurl(url)
197        for param in ('destsuffix', 'subdir'):
198            if param in decoded[5]:
199                del decoded[5][param]
200        encoded = bb.fetch2.encodeurl(decoded)
201        urls[i] = encoded
202
203    # Cleanup SRC_URI before call bb.fetch2.Fetch() since now SRC_URI is in the
204    # variable "urls", otherwise there might be errors like:
205    # The SRCREV_FORMAT variable must be set when multiple SCMs are used
206    ld = bb.data.createCopy(d)
207    ld.setVar('SRC_URI', '')
208    fetch = bb.fetch2.Fetch(urls, ld)
209    tarball_suffix = {}
210    for url in fetch.urls:
211        local = fetch.localpath(url).rstrip("/");
212        if os.path.isfile(local):
213            shutil.copy(local, ar_outdir)
214        elif os.path.isdir(local):
215            tmpdir = tempfile.mkdtemp(dir=d.getVar('ARCHIVER_WORKDIR'))
216            fetch.unpack(tmpdir, (url,))
217            # To handle recipes with more than one source, we add the "name"
218            # URL parameter as suffix. We treat it as an error when
219            # there's more than one URL without a name, or a name gets reused.
220            # This is an additional safety net, in practice the name has
221            # to be set when using the git fetcher, otherwise SRCREV cannot
222            # be set separately for each URL.
223            params = bb.fetch2.decodeurl(url)[5]
224            type = bb.fetch2.decodeurl(url)[0]
225            location = bb.fetch2.decodeurl(url)[2]
226            name = params.get('name', '')
227            if type.lower() == 'file':
228                name_tmp = location.rstrip("*").rstrip("/")
229                name = os.path.basename(name_tmp)
230            else:
231                if name in tarball_suffix:
232                    if not name:
233                        bb.fatal("Cannot determine archive names for original source because 'name' URL parameter is unset in more than one URL. Add it to at least one of these: %s %s" % (tarball_suffix[name], url))
234                    else:
235                        bb.fatal("Cannot determine archive names for original source because 'name=' URL parameter '%s' is used twice. Make it unique in: %s %s" % (tarball_suffix[name], url))
236            tarball_suffix[name] = url
237            create_tarball(d, tmpdir + '/.', name, ar_outdir)
238
239    # Emit patch series files for 'original'
240    bb.note('Writing patch series files...')
241    for patch in src_patches(d):
242        _, _, local, _, _, parm = bb.fetch.decodeurl(patch)
243        patchdir = parm.get('patchdir')
244        if patchdir:
245            series = os.path.join(ar_outdir, 'series.subdir.%s' % patchdir.replace('/', '_'))
246        else:
247            series = os.path.join(ar_outdir, 'series')
248
249        with open(series, 'a') as s:
250            s.write('%s -p%s\n' % (os.path.basename(local), parm['striplevel']))
251}
252
253python do_ar_patched() {
254
255    if d.getVarFlag('ARCHIVER_MODE', 'src') != 'patched':
256        return
257
258    # Get the ARCHIVER_OUTDIR before we reset the WORKDIR
259    ar_outdir = d.getVar('ARCHIVER_OUTDIR')
260    if not is_work_shared(d):
261        ar_workdir = d.getVar('ARCHIVER_WORKDIR')
262        d.setVar('WORKDIR', ar_workdir)
263    bb.note('Archiving the patched source...')
264    create_tarball(d, d.getVar('S'), 'patched', ar_outdir)
265}
266
267python do_ar_configured() {
268    import shutil
269
270    # Forcibly expand the sysroot paths as we're about to change WORKDIR
271    d.setVar('STAGING_DIR_HOST', d.getVar('STAGING_DIR_HOST'))
272    d.setVar('STAGING_DIR_TARGET', d.getVar('STAGING_DIR_TARGET'))
273    d.setVar('RECIPE_SYSROOT', d.getVar('RECIPE_SYSROOT'))
274    d.setVar('RECIPE_SYSROOT_NATIVE', d.getVar('RECIPE_SYSROOT_NATIVE'))
275
276    ar_outdir = d.getVar('ARCHIVER_OUTDIR')
277    if d.getVarFlag('ARCHIVER_MODE', 'src') == 'configured':
278        bb.note('Archiving the configured source...')
279        pn = d.getVar('PN')
280        # "gcc-source-${PV}" recipes don't have "do_configure"
281        # task, so we need to run "do_preconfigure" instead
282        if pn.startswith("gcc-source-"):
283            d.setVar('WORKDIR', d.getVar('ARCHIVER_WORKDIR'))
284            bb.build.exec_func('do_preconfigure', d)
285
286        # The libtool-native's do_configure will remove the
287        # ${STAGING_DATADIR}/aclocal/libtool.m4, so we can't re-run the
288        # do_configure, we archive the already configured ${S} to
289        # instead of.
290        # The kernel class functions require it to be on work-shared, we
291        # don't unpack, patch, configure again, just archive the already
292        # configured ${S}
293        elif not (pn == 'libtool-native' or is_work_shared(d)):
294            def runTask(task):
295                prefuncs = d.getVarFlag(task, 'prefuncs') or ''
296                for func in prefuncs.split():
297                    if func != "sysroot_cleansstate":
298                        bb.build.exec_func(func, d)
299                bb.build.exec_func(task, d)
300                postfuncs = d.getVarFlag(task, 'postfuncs') or ''
301                for func in postfuncs.split():
302                    if func != 'do_qa_configure':
303                        bb.build.exec_func(func, d)
304
305            # Change the WORKDIR to make do_configure run in another dir.
306            d.setVar('WORKDIR', d.getVar('ARCHIVER_WORKDIR'))
307
308            preceeds = bb.build.preceedtask('do_configure', False, d)
309            for task in preceeds:
310                if task != 'do_patch' and task != 'do_prepare_recipe_sysroot':
311                    runTask(task)
312            runTask('do_configure')
313
314        srcdir = d.getVar('S')
315        builddir = d.getVar('B')
316        if srcdir != builddir:
317            if os.path.exists(builddir):
318                oe.path.copytree(builddir, os.path.join(srcdir, \
319                    'build.%s.ar_configured' % d.getVar('PF')))
320        create_tarball(d, srcdir, 'configured', ar_outdir)
321}
322
323python do_ar_mirror() {
324    import subprocess
325
326    src_uri = (d.getVar('SRC_URI') or '').split()
327    if len(src_uri) == 0:
328        return
329
330    dl_dir = d.getVar('DL_DIR')
331    mirror_exclusions = (d.getVar('ARCHIVER_MIRROR_EXCLUDE') or '').split()
332    mirror_mode = d.getVarFlag('ARCHIVER_MODE', 'mirror')
333    have_mirror_tarballs = d.getVar('BB_GENERATE_MIRROR_TARBALLS')
334
335    if mirror_mode == 'combined':
336        destdir = d.getVar('ARCHIVER_COMBINED_MIRRORDIR')
337    elif mirror_mode == 'split':
338        destdir = d.getVar('ARCHIVER_OUTDIR')
339    else:
340        bb.fatal('Invalid ARCHIVER_MODE[mirror]: %s' % (mirror_mode))
341
342    if not have_mirror_tarballs:
343        bb.fatal('Using `ARCHIVER_MODE[src] = "mirror"` depends on setting `BB_GENERATE_MIRROR_TARBALLS = "1"`')
344
345    def is_excluded(url):
346        for prefix in mirror_exclusions:
347            if url.startswith(prefix):
348                return True
349        return False
350
351    bb.note('Archiving the source as a mirror...')
352
353    bb.utils.mkdirhier(destdir)
354
355    fetcher = bb.fetch2.Fetch(src_uri, d)
356
357    for ud in fetcher.expanded_urldata():
358        if is_excluded(ud.url):
359            bb.note('Skipping excluded url: %s' % (ud.url))
360            continue
361
362        bb.note('Archiving url: %s' % (ud.url))
363        ud.setup_localpath(d)
364        localpath = None
365
366        # Check for mirror tarballs first. We will archive the first mirror
367        # tarball that we find as it's assumed that we just need one.
368        for mirror_fname in ud.mirrortarballs:
369            mirror_path = os.path.join(dl_dir, mirror_fname)
370            if os.path.exists(mirror_path):
371                bb.note('Found mirror tarball: %s' % (mirror_path))
372                localpath = mirror_path
373                break
374
375        if len(ud.mirrortarballs) and not localpath:
376            bb.warn('Mirror tarballs are listed for a source but none are present. ' \
377                    'Falling back to original download.\n' \
378                    'SRC_URI = %s' % (ud.url))
379
380        # Check original download
381        if not localpath:
382            bb.note('Using original download: %s' % (ud.localpath))
383            localpath = ud.localpath
384
385        if not localpath or not os.path.exists(localpath):
386            bb.fatal('Original download is missing for a source.\n' \
387                        'SRC_URI = %s' % (ud.url))
388
389        # We now have an appropriate localpath
390        bb.note('Copying source mirror')
391        cmd = 'cp -fpPRH %s %s' % (localpath, destdir)
392        subprocess.check_call(cmd, shell=True)
393}
394
395def exclude_useless_paths(tarinfo):
396    if tarinfo.isdir():
397        if tarinfo.name.endswith('/temp') or tarinfo.name.endswith('/patches') or tarinfo.name.endswith('/.pc'):
398            return None
399        elif tarinfo.name == 'temp' or tarinfo.name == 'patches' or tarinfo.name == '.pc':
400            return None
401    return tarinfo
402
403def create_tarball(d, srcdir, suffix, ar_outdir):
404    """
405    create the tarball from srcdir
406    """
407    import tarfile
408
409    # Make sure we are only creating a single tarball for gcc sources
410    if (d.getVar('SRC_URI') == ""):
411        return
412
413    # For the kernel archive, srcdir may just be a link to the
414    # work-shared location. Use os.path.realpath to make sure
415    # that we archive the actual directory and not just the link.
416    srcdir = os.path.realpath(srcdir)
417
418    compression_method = d.getVarFlag('ARCHIVER_MODE', 'compression')
419    bb.utils.mkdirhier(ar_outdir)
420    if suffix:
421        filename = '%s-%s.tar.%s' % (d.getVar('PF'), suffix, compression_method)
422    else:
423        filename = '%s.tar.%s' % (d.getVar('PF'), compression_method)
424    tarname = os.path.join(ar_outdir, filename)
425
426    bb.note('Creating %s' % tarname)
427    tar = tarfile.open(tarname, 'w:%s' % compression_method)
428    tar.add(srcdir, arcname=os.path.basename(srcdir), filter=exclude_useless_paths)
429    tar.close()
430
431# creating .diff.gz between source.orig and source
432def create_diff_gz(d, src_orig, src, ar_outdir):
433
434    import subprocess
435
436    if not os.path.isdir(src) or not os.path.isdir(src_orig):
437        return
438
439    # The diff --exclude can't exclude the file with path, so we copy
440    # the patched source, and remove the files that we'd like to
441    # exclude.
442    src_patched = src + '.patched'
443    oe.path.copyhardlinktree(src, src_patched)
444    for i in d.getVarFlag('ARCHIVER_MODE', 'diff-exclude').split():
445        bb.utils.remove(os.path.join(src_orig, i), recurse=True)
446        bb.utils.remove(os.path.join(src_patched, i), recurse=True)
447
448    dirname = os.path.dirname(src)
449    basename = os.path.basename(src)
450    bb.utils.mkdirhier(ar_outdir)
451    cwd = os.getcwd()
452    try:
453        os.chdir(dirname)
454        out_file = os.path.join(ar_outdir, '%s-diff.gz' % d.getVar('PF'))
455        diff_cmd = 'diff -Naur %s.orig %s.patched | gzip -c > %s' % (basename, basename, out_file)
456        subprocess.check_call(diff_cmd, shell=True)
457        bb.utils.remove(src_patched, recurse=True)
458    finally:
459        os.chdir(cwd)
460
461def is_work_shared(d):
462    pn = d.getVar('PN')
463    return bb.data.inherits_class('kernel', d) or pn.startswith('gcc-source')
464
465# Run do_unpack and do_patch
466python do_unpack_and_patch() {
467    if d.getVarFlag('ARCHIVER_MODE', 'src') not in \
468            [ 'patched', 'configured'] and \
469            d.getVarFlag('ARCHIVER_MODE', 'diff') != '1':
470        return
471    ar_outdir = d.getVar('ARCHIVER_OUTDIR')
472    ar_workdir = d.getVar('ARCHIVER_WORKDIR')
473    ar_sysroot_native = d.getVar('STAGING_DIR_NATIVE')
474    pn = d.getVar('PN')
475
476    # The kernel class functions require it to be on work-shared, so we don't change WORKDIR
477    if not is_work_shared(d):
478        # Change the WORKDIR to make do_unpack do_patch run in another dir.
479        d.setVar('WORKDIR', ar_workdir)
480        # Restore the original path to recipe's native sysroot (it's relative to WORKDIR).
481        d.setVar('STAGING_DIR_NATIVE', ar_sysroot_native)
482
483        # The changed 'WORKDIR' also caused 'B' changed, create dir 'B' for the
484        # possibly requiring of the following tasks (such as some recipes's
485        # do_patch required 'B' existed).
486        bb.utils.mkdirhier(d.getVar('B'))
487
488        bb.build.exec_func('do_unpack', d)
489
490    # Save the original source for creating the patches
491    if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1':
492        src = d.getVar('S').rstrip('/')
493        src_orig = '%s.orig' % src
494        oe.path.copytree(src, src_orig)
495
496    if bb.data.inherits_class('dos2unix', d):
497        bb.build.exec_func('do_convert_crlf_to_lf', d)
498
499    # Make sure gcc and kernel sources are patched only once
500    if not (d.getVar('SRC_URI') == "" or is_work_shared(d)):
501        bb.build.exec_func('do_patch', d)
502
503    # Create the patches
504    if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1':
505        bb.note('Creating diff gz...')
506        create_diff_gz(d, src_orig, src, ar_outdir)
507        bb.utils.remove(src_orig, recurse=True)
508}
509
510# BBINCLUDED is special (excluded from basehash signature
511# calculation). Using it in a task signature can cause "basehash
512# changed" errors.
513#
514# Depending on BBINCLUDED also causes do_ar_recipe to run again
515# for unrelated changes, like adding or removing buildhistory.bbclass.
516#
517# For these reasons we ignore the dependency completely. The versioning
518# of the output file ensures that we create it each time the recipe
519# gets rebuilt, at least as long as a PR server is used. We also rely
520# on that mechanism to catch changes in the file content, because the
521# file content is not part of the task signature either.
522do_ar_recipe[vardepsexclude] += "BBINCLUDED"
523python do_ar_recipe () {
524    """
525    archive the recipe, including .bb and .inc.
526    """
527    import re
528    import shutil
529
530    require_re = re.compile( r"require\s+(.+)" )
531    include_re = re.compile( r"include\s+(.+)" )
532    bbfile = d.getVar('FILE')
533    outdir = os.path.join(d.getVar('WORKDIR'), \
534            '%s-recipe' % d.getVar('PF'))
535    bb.utils.mkdirhier(outdir)
536    shutil.copy(bbfile, outdir)
537
538    pn = d.getVar('PN')
539    bbappend_files = d.getVar('BBINCLUDED').split()
540    # If recipe name is aa, we need to match files like aa.bbappend and aa_1.1.bbappend
541    # Files like aa1.bbappend or aa1_1.1.bbappend must be excluded.
542    bbappend_re = re.compile( r".*/%s_[^/]*\.bbappend$" % re.escape(pn))
543    bbappend_re1 = re.compile( r".*/%s\.bbappend$" % re.escape(pn))
544    for file in bbappend_files:
545        if bbappend_re.match(file) or bbappend_re1.match(file):
546            shutil.copy(file, outdir)
547
548    dirname = os.path.dirname(bbfile)
549    bbpath = '%s:%s' % (dirname, d.getVar('BBPATH'))
550    f = open(bbfile, 'r')
551    for line in f.readlines():
552        incfile = None
553        if require_re.match(line):
554            incfile = require_re.match(line).group(1)
555        elif include_re.match(line):
556            incfile = include_re.match(line).group(1)
557        if incfile:
558            incfile = d.expand(incfile)
559        if incfile:
560            incfile = bb.utils.which(bbpath, incfile)
561        if incfile:
562            shutil.copy(incfile, outdir)
563
564    create_tarball(d, outdir, 'recipe', d.getVar('ARCHIVER_OUTDIR'))
565    bb.utils.remove(outdir, recurse=True)
566}
567
568python do_dumpdata () {
569    """
570    dump environment data to ${PF}-showdata.dump
571    """
572
573    dumpfile = os.path.join(d.getVar('ARCHIVER_OUTDIR'), \
574        '%s-showdata.dump' % d.getVar('PF'))
575    bb.note('Dumping metadata into %s' % dumpfile)
576    with open(dumpfile, "w") as f:
577        # emit variables and shell functions
578        bb.data.emit_env(f, d, True)
579        # emit the metadata which isn't valid shell
580        for e in d.keys():
581            if d.getVarFlag(e, "python", False):
582                f.write("\npython %s () {\n%s}\n" % (e, d.getVar(e, False)))
583}
584
585SSTATETASKS += "do_deploy_archives"
586do_deploy_archives () {
587    bbnote "Deploying source archive files from ${ARCHIVER_TOPDIR} to ${DEPLOY_DIR_SRC}."
588}
589python do_deploy_archives_setscene () {
590    sstate_setscene(d)
591}
592do_deploy_archives[dirs] = "${ARCHIVER_TOPDIR}"
593do_deploy_archives[sstate-inputdirs] = "${ARCHIVER_TOPDIR}"
594do_deploy_archives[sstate-outputdirs] = "${DEPLOY_DIR_SRC}"
595addtask do_deploy_archives_setscene
596
597addtask do_ar_original after do_unpack
598addtask do_unpack_and_patch after do_patch do_preconfigure
599addtask do_ar_patched after do_unpack_and_patch
600addtask do_ar_configured after do_unpack_and_patch
601addtask do_ar_mirror after do_fetch
602addtask do_dumpdata
603addtask do_ar_recipe
604addtask do_deploy_archives
605do_build[recrdeptask] += "do_deploy_archives"
606do_rootfs[recrdeptask] += "do_deploy_archives"
607do_populate_sdk[recrdeptask] += "do_deploy_archives"
608
609python () {
610    # Add tasks in the correct order, specifically for linux-yocto to avoid race condition.
611    # sstatesig.py:sstate_rundepfilter has special support that excludes this dependency
612    # so that do_kernel_configme does not need to run again when do_unpack_and_patch
613    # gets added or removed (by adding or removing archiver.bbclass).
614    if bb.data.inherits_class('kernel-yocto', d):
615        bb.build.addtask('do_kernel_configme', 'do_configure', 'do_unpack_and_patch', d)
616}
617