1eb8dc403SDave Cobbley# ex:ts=4:sw=4:sts=4:et
2eb8dc403SDave Cobbley# -*- tab-width: 4; c-basic-offset: 4; indent-tabs-mode: nil -*-
3eb8dc403SDave Cobbley#
4eb8dc403SDave Cobbley# This bbclass is used for creating archive for:
5eb8dc403SDave Cobbley# 1) original (or unpacked) source: ARCHIVER_MODE[src] = "original"
6eb8dc403SDave Cobbley# 2) patched source: ARCHIVER_MODE[src] = "patched" (default)
7eb8dc403SDave Cobbley# 3) configured source: ARCHIVER_MODE[src] = "configured"
8eb8dc403SDave Cobbley# 4) The patches between do_unpack and do_patch:
9eb8dc403SDave Cobbley#    ARCHIVER_MODE[diff] = "1"
10eb8dc403SDave Cobbley#    And you can set the one that you'd like to exclude from the diff:
11eb8dc403SDave Cobbley#    ARCHIVER_MODE[diff-exclude] ?= ".pc autom4te.cache patches"
12eb8dc403SDave Cobbley# 5) The environment data, similar to 'bitbake -e recipe':
13eb8dc403SDave Cobbley#    ARCHIVER_MODE[dumpdata] = "1"
14eb8dc403SDave Cobbley# 6) The recipe (.bb and .inc): ARCHIVER_MODE[recipe] = "1"
15eb8dc403SDave Cobbley# 7) Whether output the .src.rpm package:
16eb8dc403SDave Cobbley#    ARCHIVER_MODE[srpm] = "1"
17eb8dc403SDave Cobbley# 8) Filter the license, the recipe whose license in
18eb8dc403SDave Cobbley#    COPYLEFT_LICENSE_INCLUDE will be included, and in
19eb8dc403SDave Cobbley#    COPYLEFT_LICENSE_EXCLUDE will be excluded.
20eb8dc403SDave Cobbley#    COPYLEFT_LICENSE_INCLUDE = 'GPL* LGPL*'
21eb8dc403SDave Cobbley#    COPYLEFT_LICENSE_EXCLUDE = 'CLOSED Proprietary'
22eb8dc403SDave Cobbley# 9) The recipe type that will be archived:
23eb8dc403SDave Cobbley#    COPYLEFT_RECIPE_TYPES = 'target'
24eb8dc403SDave Cobbley#
25eb8dc403SDave Cobbley
26eb8dc403SDave Cobbley# Don't filter the license by default
27eb8dc403SDave CobbleyCOPYLEFT_LICENSE_INCLUDE ?= ''
28eb8dc403SDave CobbleyCOPYLEFT_LICENSE_EXCLUDE ?= ''
29eb8dc403SDave Cobbley# Create archive for all the recipe types
30eb8dc403SDave CobbleyCOPYLEFT_RECIPE_TYPES ?= 'target native nativesdk cross crosssdk cross-canadian'
31eb8dc403SDave Cobbleyinherit copyleft_filter
32eb8dc403SDave Cobbley
33eb8dc403SDave CobbleyARCHIVER_MODE[srpm] ?= "0"
34eb8dc403SDave CobbleyARCHIVER_MODE[src] ?= "patched"
35eb8dc403SDave CobbleyARCHIVER_MODE[diff] ?= "0"
36eb8dc403SDave CobbleyARCHIVER_MODE[diff-exclude] ?= ".pc autom4te.cache patches"
37eb8dc403SDave CobbleyARCHIVER_MODE[dumpdata] ?= "0"
38eb8dc403SDave CobbleyARCHIVER_MODE[recipe] ?= "0"
39eb8dc403SDave Cobbley
40eb8dc403SDave CobbleyDEPLOY_DIR_SRC ?= "${DEPLOY_DIR}/sources"
41eb8dc403SDave CobbleyARCHIVER_TOPDIR ?= "${WORKDIR}/deploy-sources"
42eb8dc403SDave CobbleyARCHIVER_OUTDIR = "${ARCHIVER_TOPDIR}/${TARGET_SYS}/${PF}/"
43eb8dc403SDave CobbleyARCHIVER_WORKDIR = "${WORKDIR}/archiver-work/"
44eb8dc403SDave Cobbley
45eb8dc403SDave Cobbleydo_dumpdata[dirs] = "${ARCHIVER_OUTDIR}"
46eb8dc403SDave Cobbleydo_ar_recipe[dirs] = "${ARCHIVER_OUTDIR}"
47eb8dc403SDave Cobbleydo_ar_original[dirs] = "${ARCHIVER_OUTDIR} ${ARCHIVER_WORKDIR}"
48eb8dc403SDave Cobbleydo_deploy_archives[dirs] = "${WORKDIR}"
49eb8dc403SDave Cobbley
50eb8dc403SDave Cobbley# This is a convenience for the shell script to use it
51eb8dc403SDave Cobbley
52eb8dc403SDave Cobbley
53eb8dc403SDave Cobbleypython () {
54eb8dc403SDave Cobbley    pn = d.getVar('PN')
55eb8dc403SDave Cobbley    assume_provided = (d.getVar("ASSUME_PROVIDED") or "").split()
56eb8dc403SDave Cobbley    if pn in assume_provided:
57eb8dc403SDave Cobbley        for p in d.getVar("PROVIDES").split():
58eb8dc403SDave Cobbley            if p != pn:
59eb8dc403SDave Cobbley                pn = p
60eb8dc403SDave Cobbley                break
61eb8dc403SDave Cobbley
62eb8dc403SDave Cobbley    included, reason = copyleft_should_include(d)
63eb8dc403SDave Cobbley    if not included:
64eb8dc403SDave Cobbley        bb.debug(1, 'archiver: %s is excluded: %s' % (pn, reason))
65eb8dc403SDave Cobbley        return
66eb8dc403SDave Cobbley    else:
67eb8dc403SDave Cobbley        bb.debug(1, 'archiver: %s is included: %s' % (pn, reason))
68eb8dc403SDave Cobbley
69eb8dc403SDave Cobbley
70eb8dc403SDave Cobbley    # glibc-locale: do_fetch, do_unpack and do_patch tasks have been deleted,
71eb8dc403SDave Cobbley    # so avoid archiving source here.
72eb8dc403SDave Cobbley    if pn.startswith('glibc-locale'):
73eb8dc403SDave Cobbley        return
74eb8dc403SDave Cobbley
75eb8dc403SDave Cobbley    # We just archive gcc-source for all the gcc related recipes
76eb8dc403SDave Cobbley    if d.getVar('BPN') in ['gcc', 'libgcc'] \
77eb8dc403SDave Cobbley            and not pn.startswith('gcc-source'):
78eb8dc403SDave Cobbley        bb.debug(1, 'archiver: %s is excluded, covered by gcc-source' % pn)
79eb8dc403SDave Cobbley        return
80eb8dc403SDave Cobbley
81eb8dc403SDave Cobbley    ar_src = d.getVarFlag('ARCHIVER_MODE', 'src')
82eb8dc403SDave Cobbley    ar_dumpdata = d.getVarFlag('ARCHIVER_MODE', 'dumpdata')
83eb8dc403SDave Cobbley    ar_recipe = d.getVarFlag('ARCHIVER_MODE', 'recipe')
84eb8dc403SDave Cobbley
85eb8dc403SDave Cobbley    if ar_src == "original":
86eb8dc403SDave Cobbley        d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_original' % pn)
87eb8dc403SDave Cobbley        # 'patched' and 'configured' invoke do_unpack_and_patch because
88eb8dc403SDave Cobbley        # do_ar_patched resp. do_ar_configured depend on it, but for 'original'
89eb8dc403SDave Cobbley        # we have to add it explicitly.
90eb8dc403SDave Cobbley        if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1':
91eb8dc403SDave Cobbley            d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_unpack_and_patch' % pn)
92eb8dc403SDave Cobbley    elif ar_src == "patched":
93eb8dc403SDave Cobbley        d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_patched' % pn)
94eb8dc403SDave Cobbley    elif ar_src == "configured":
95eb8dc403SDave Cobbley        # We can't use "addtask do_ar_configured after do_configure" since it
96eb8dc403SDave Cobbley        # will cause the deptask of do_populate_sysroot to run not matter what
97eb8dc403SDave Cobbley        # archives we need, so we add the depends here.
98eb8dc403SDave Cobbley
99eb8dc403SDave Cobbley        # There is a corner case with "gcc-source-${PV}" recipes, they don't have
100eb8dc403SDave Cobbley        # the "do_configure" task, so we need to use "do_preconfigure"
101*1a4b7ee2SBrad Bishop        def hasTask(task):
102*1a4b7ee2SBrad Bishop            return bool(d.getVarFlag(task, "task", False)) and not bool(d.getVarFlag(task, "noexec", False))
103*1a4b7ee2SBrad Bishop
104*1a4b7ee2SBrad Bishop        if hasTask("do_preconfigure"):
105eb8dc403SDave Cobbley            d.appendVarFlag('do_ar_configured', 'depends', ' %s:do_preconfigure' % pn)
106*1a4b7ee2SBrad Bishop        elif hasTask("do_configure"):
107eb8dc403SDave Cobbley            d.appendVarFlag('do_ar_configured', 'depends', ' %s:do_configure' % pn)
108eb8dc403SDave Cobbley        d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_configured' % pn)
109eb8dc403SDave Cobbley
110eb8dc403SDave Cobbley    elif ar_src:
111eb8dc403SDave Cobbley        bb.fatal("Invalid ARCHIVER_MODE[src]: %s" % ar_src)
112eb8dc403SDave Cobbley
113eb8dc403SDave Cobbley    if ar_dumpdata == "1":
114eb8dc403SDave Cobbley        d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_dumpdata' % pn)
115eb8dc403SDave Cobbley
116eb8dc403SDave Cobbley    if ar_recipe == "1":
117eb8dc403SDave Cobbley        d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_ar_recipe' % pn)
118eb8dc403SDave Cobbley
119eb8dc403SDave Cobbley    # Output the SRPM package
120eb8dc403SDave Cobbley    if d.getVarFlag('ARCHIVER_MODE', 'srpm') == "1" and d.getVar('PACKAGES'):
121eb8dc403SDave Cobbley        if "package_rpm" in d.getVar('PACKAGE_CLASSES'):
122eb8dc403SDave Cobbley            d.appendVarFlag('do_deploy_archives', 'depends', ' %s:do_package_write_rpm' % pn)
123eb8dc403SDave Cobbley            if ar_dumpdata == "1":
124eb8dc403SDave Cobbley                d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_dumpdata' % pn)
125eb8dc403SDave Cobbley            if ar_recipe == "1":
126eb8dc403SDave Cobbley                d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_recipe' % pn)
127eb8dc403SDave Cobbley            if ar_src == "original":
128eb8dc403SDave Cobbley                d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_original' % pn)
129eb8dc403SDave Cobbley            elif ar_src == "patched":
130eb8dc403SDave Cobbley                d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_patched' % pn)
131eb8dc403SDave Cobbley            elif ar_src == "configured":
132eb8dc403SDave Cobbley                d.appendVarFlag('do_package_write_rpm', 'depends', ' %s:do_ar_configured' % pn)
133eb8dc403SDave Cobbley        else:
134eb8dc403SDave Cobbley            bb.fatal("ARCHIVER_MODE[srpm] needs package_rpm in PACKAGE_CLASSES")
135eb8dc403SDave Cobbley}
136eb8dc403SDave Cobbley
137eb8dc403SDave Cobbley# Take all the sources for a recipe and puts them in WORKDIR/archiver-work/.
138eb8dc403SDave Cobbley# Files in SRC_URI are copied directly, anything that's a directory
139eb8dc403SDave Cobbley# (e.g. git repositories) is "unpacked" and then put into a tarball.
140eb8dc403SDave Cobbleypython do_ar_original() {
141eb8dc403SDave Cobbley
142eb8dc403SDave Cobbley    import shutil, tempfile
143eb8dc403SDave Cobbley
144eb8dc403SDave Cobbley    if d.getVarFlag('ARCHIVER_MODE', 'src') != "original":
145eb8dc403SDave Cobbley        return
146eb8dc403SDave Cobbley
147eb8dc403SDave Cobbley    ar_outdir = d.getVar('ARCHIVER_OUTDIR')
148eb8dc403SDave Cobbley    bb.note('Archiving the original source...')
149eb8dc403SDave Cobbley    urls = d.getVar("SRC_URI").split()
150eb8dc403SDave Cobbley    # destsuffix (git fetcher) and subdir (everything else) are allowed to be
151eb8dc403SDave Cobbley    # absolute paths (for example, destsuffix=${S}/foobar).
152eb8dc403SDave Cobbley    # That messes with unpacking inside our tmpdir below, because the fetchers
153eb8dc403SDave Cobbley    # will then unpack in that directory and completely ignore the tmpdir.
154eb8dc403SDave Cobbley    # That breaks parallel tasks relying on ${S}, like do_compile.
155eb8dc403SDave Cobbley    #
156eb8dc403SDave Cobbley    # To solve this, we remove these parameters from all URLs.
157eb8dc403SDave Cobbley    # We do this even for relative paths because it makes the content of the
158eb8dc403SDave Cobbley    # archives more useful (no extra paths that are only used during
159eb8dc403SDave Cobbley    # compilation).
160eb8dc403SDave Cobbley    for i, url in enumerate(urls):
161eb8dc403SDave Cobbley        decoded = bb.fetch2.decodeurl(url)
162eb8dc403SDave Cobbley        for param in ('destsuffix', 'subdir'):
163eb8dc403SDave Cobbley            if param in decoded[5]:
164eb8dc403SDave Cobbley                del decoded[5][param]
165eb8dc403SDave Cobbley        encoded = bb.fetch2.encodeurl(decoded)
166eb8dc403SDave Cobbley        urls[i] = encoded
167eb8dc403SDave Cobbley    fetch = bb.fetch2.Fetch(urls, d)
168eb8dc403SDave Cobbley    tarball_suffix = {}
169eb8dc403SDave Cobbley    for url in fetch.urls:
170eb8dc403SDave Cobbley        local = fetch.localpath(url).rstrip("/");
171eb8dc403SDave Cobbley        if os.path.isfile(local):
172eb8dc403SDave Cobbley            shutil.copy(local, ar_outdir)
173eb8dc403SDave Cobbley        elif os.path.isdir(local):
174eb8dc403SDave Cobbley            tmpdir = tempfile.mkdtemp(dir=d.getVar('ARCHIVER_WORKDIR'))
175eb8dc403SDave Cobbley            fetch.unpack(tmpdir, (url,))
176eb8dc403SDave Cobbley            # To handle recipes with more than one source, we add the "name"
177eb8dc403SDave Cobbley            # URL parameter as suffix. We treat it as an error when
178eb8dc403SDave Cobbley            # there's more than one URL without a name, or a name gets reused.
179eb8dc403SDave Cobbley            # This is an additional safety net, in practice the name has
180eb8dc403SDave Cobbley            # to be set when using the git fetcher, otherwise SRCREV cannot
181eb8dc403SDave Cobbley            # be set separately for each URL.
182eb8dc403SDave Cobbley            params = bb.fetch2.decodeurl(url)[5]
183eb8dc403SDave Cobbley            type = bb.fetch2.decodeurl(url)[0]
184eb8dc403SDave Cobbley            location = bb.fetch2.decodeurl(url)[2]
185eb8dc403SDave Cobbley            name = params.get('name', '')
186eb8dc403SDave Cobbley            if type.lower() == 'file':
187eb8dc403SDave Cobbley                name_tmp = location.rstrip("*").rstrip("/")
188eb8dc403SDave Cobbley                name = os.path.basename(name_tmp)
189eb8dc403SDave Cobbley            else:
190eb8dc403SDave Cobbley                if name in tarball_suffix:
191eb8dc403SDave Cobbley                    if not name:
192eb8dc403SDave Cobbley                        bb.fatal("Cannot determine archive names for original source because 'name' URL parameter is unset in more than one URL. Add it to at least one of these: %s %s" % (tarball_suffix[name], url))
193eb8dc403SDave Cobbley                    else:
194eb8dc403SDave Cobbley                        bb.fatal("Cannot determine archive names for original source because 'name=' URL parameter '%s' is used twice. Make it unique in: %s %s" % (tarball_suffix[name], url))
195eb8dc403SDave Cobbley            tarball_suffix[name] = url
196eb8dc403SDave Cobbley            create_tarball(d, tmpdir + '/.', name, ar_outdir)
197eb8dc403SDave Cobbley
198eb8dc403SDave Cobbley    # Emit patch series files for 'original'
199eb8dc403SDave Cobbley    bb.note('Writing patch series files...')
200eb8dc403SDave Cobbley    for patch in src_patches(d):
201eb8dc403SDave Cobbley        _, _, local, _, _, parm = bb.fetch.decodeurl(patch)
202eb8dc403SDave Cobbley        patchdir = parm.get('patchdir')
203eb8dc403SDave Cobbley        if patchdir:
204eb8dc403SDave Cobbley            series = os.path.join(ar_outdir, 'series.subdir.%s' % patchdir.replace('/', '_'))
205eb8dc403SDave Cobbley        else:
206eb8dc403SDave Cobbley            series = os.path.join(ar_outdir, 'series')
207eb8dc403SDave Cobbley
208eb8dc403SDave Cobbley        with open(series, 'a') as s:
209eb8dc403SDave Cobbley            s.write('%s -p%s\n' % (os.path.basename(local), parm['striplevel']))
210eb8dc403SDave Cobbley}
211eb8dc403SDave Cobbley
212eb8dc403SDave Cobbleypython do_ar_patched() {
213eb8dc403SDave Cobbley
214eb8dc403SDave Cobbley    if d.getVarFlag('ARCHIVER_MODE', 'src') != 'patched':
215eb8dc403SDave Cobbley        return
216eb8dc403SDave Cobbley
217eb8dc403SDave Cobbley    # Get the ARCHIVER_OUTDIR before we reset the WORKDIR
218eb8dc403SDave Cobbley    ar_outdir = d.getVar('ARCHIVER_OUTDIR')
219eb8dc403SDave Cobbley    ar_workdir = d.getVar('ARCHIVER_WORKDIR')
220eb8dc403SDave Cobbley    bb.note('Archiving the patched source...')
221eb8dc403SDave Cobbley    d.setVar('WORKDIR', ar_workdir)
222eb8dc403SDave Cobbley    create_tarball(d, d.getVar('S'), 'patched', ar_outdir)
223eb8dc403SDave Cobbley}
224eb8dc403SDave Cobbley
225eb8dc403SDave Cobbleypython do_ar_configured() {
226eb8dc403SDave Cobbley    import shutil
227eb8dc403SDave Cobbley
228eb8dc403SDave Cobbley    # Forcibly expand the sysroot paths as we're about to change WORKDIR
229eb8dc403SDave Cobbley    d.setVar('STAGING_DIR_HOST', d.getVar('STAGING_DIR_HOST'))
230eb8dc403SDave Cobbley    d.setVar('STAGING_DIR_TARGET', d.getVar('STAGING_DIR_TARGET'))
231eb8dc403SDave Cobbley    d.setVar('RECIPE_SYSROOT', d.getVar('RECIPE_SYSROOT'))
232eb8dc403SDave Cobbley    d.setVar('RECIPE_SYSROOT_NATIVE', d.getVar('RECIPE_SYSROOT_NATIVE'))
233eb8dc403SDave Cobbley
234eb8dc403SDave Cobbley    ar_outdir = d.getVar('ARCHIVER_OUTDIR')
235eb8dc403SDave Cobbley    if d.getVarFlag('ARCHIVER_MODE', 'src') == 'configured':
236eb8dc403SDave Cobbley        bb.note('Archiving the configured source...')
237eb8dc403SDave Cobbley        pn = d.getVar('PN')
238eb8dc403SDave Cobbley        # "gcc-source-${PV}" recipes don't have "do_configure"
239eb8dc403SDave Cobbley        # task, so we need to run "do_preconfigure" instead
240eb8dc403SDave Cobbley        if pn.startswith("gcc-source-"):
241eb8dc403SDave Cobbley            d.setVar('WORKDIR', d.getVar('ARCHIVER_WORKDIR'))
242eb8dc403SDave Cobbley            bb.build.exec_func('do_preconfigure', d)
243eb8dc403SDave Cobbley
244eb8dc403SDave Cobbley        # The libtool-native's do_configure will remove the
245eb8dc403SDave Cobbley        # ${STAGING_DATADIR}/aclocal/libtool.m4, so we can't re-run the
246eb8dc403SDave Cobbley        # do_configure, we archive the already configured ${S} to
247eb8dc403SDave Cobbley        # instead of.
248eb8dc403SDave Cobbley        elif pn != 'libtool-native':
249*1a4b7ee2SBrad Bishop            def runTask(task):
250*1a4b7ee2SBrad Bishop                prefuncs = d.getVarFlag(task, 'prefuncs') or ''
251*1a4b7ee2SBrad Bishop                for func in prefuncs.split():
252eb8dc403SDave Cobbley                    if func != "sysroot_cleansstate":
253eb8dc403SDave Cobbley                        bb.build.exec_func(func, d)
254*1a4b7ee2SBrad Bishop                bb.build.exec_func(task, d)
255*1a4b7ee2SBrad Bishop                postfuncs = d.getVarFlag(task, 'postfuncs') or ''
256*1a4b7ee2SBrad Bishop                for func in postfuncs.split():
257*1a4b7ee2SBrad Bishop                    if func != 'do_qa_configure':
258eb8dc403SDave Cobbley                        bb.build.exec_func(func, d)
259*1a4b7ee2SBrad Bishop
260*1a4b7ee2SBrad Bishop            # Change the WORKDIR to make do_configure run in another dir.
261*1a4b7ee2SBrad Bishop            d.setVar('WORKDIR', d.getVar('ARCHIVER_WORKDIR'))
262*1a4b7ee2SBrad Bishop
263*1a4b7ee2SBrad Bishop            preceeds = bb.build.preceedtask('do_configure', False, d)
264*1a4b7ee2SBrad Bishop            for task in preceeds:
265*1a4b7ee2SBrad Bishop                if task != 'do_patch' and task != 'do_prepare_recipe_sysroot':
266*1a4b7ee2SBrad Bishop                    runTask(task)
267*1a4b7ee2SBrad Bishop            runTask('do_configure')
268*1a4b7ee2SBrad Bishop
269eb8dc403SDave Cobbley        srcdir = d.getVar('S')
270eb8dc403SDave Cobbley        builddir = d.getVar('B')
271eb8dc403SDave Cobbley        if srcdir != builddir:
272eb8dc403SDave Cobbley            if os.path.exists(builddir):
273eb8dc403SDave Cobbley                oe.path.copytree(builddir, os.path.join(srcdir, \
274eb8dc403SDave Cobbley                    'build.%s.ar_configured' % d.getVar('PF')))
275eb8dc403SDave Cobbley        create_tarball(d, srcdir, 'configured', ar_outdir)
276eb8dc403SDave Cobbley}
277eb8dc403SDave Cobbley
278c4ea075dSBrad Bishopdef exclude_useless_paths(tarinfo):
279c4ea075dSBrad Bishop    if tarinfo.isdir():
280c4ea075dSBrad Bishop        if tarinfo.name.endswith('/temp') or tarinfo.name.endswith('/patches') or tarinfo.name.endswith('/.pc'):
281c4ea075dSBrad Bishop            return None
282c4ea075dSBrad Bishop        elif tarinfo.name == 'temp' or tarinfo.name == 'patches' or tarinfo.name == '.pc':
283c4ea075dSBrad Bishop            return None
284c4ea075dSBrad Bishop    return tarinfo
285c4ea075dSBrad Bishop
286eb8dc403SDave Cobbleydef create_tarball(d, srcdir, suffix, ar_outdir):
287eb8dc403SDave Cobbley    """
288eb8dc403SDave Cobbley    create the tarball from srcdir
289eb8dc403SDave Cobbley    """
290eb8dc403SDave Cobbley    import tarfile
291eb8dc403SDave Cobbley
292eb8dc403SDave Cobbley    # Make sure we are only creating a single tarball for gcc sources
293eb8dc403SDave Cobbley    if (d.getVar('SRC_URI') == ""):
294eb8dc403SDave Cobbley        return
295eb8dc403SDave Cobbley
296eb8dc403SDave Cobbley    # For the kernel archive, srcdir may just be a link to the
297eb8dc403SDave Cobbley    # work-shared location. Use os.path.realpath to make sure
298eb8dc403SDave Cobbley    # that we archive the actual directory and not just the link.
299eb8dc403SDave Cobbley    srcdir = os.path.realpath(srcdir)
300eb8dc403SDave Cobbley
301eb8dc403SDave Cobbley    bb.utils.mkdirhier(ar_outdir)
302eb8dc403SDave Cobbley    if suffix:
303eb8dc403SDave Cobbley        filename = '%s-%s.tar.gz' % (d.getVar('PF'), suffix)
304eb8dc403SDave Cobbley    else:
305eb8dc403SDave Cobbley        filename = '%s.tar.gz' % d.getVar('PF')
306eb8dc403SDave Cobbley    tarname = os.path.join(ar_outdir, filename)
307eb8dc403SDave Cobbley
308eb8dc403SDave Cobbley    bb.note('Creating %s' % tarname)
309eb8dc403SDave Cobbley    tar = tarfile.open(tarname, 'w:gz')
310c4ea075dSBrad Bishop    tar.add(srcdir, arcname=os.path.basename(srcdir), filter=exclude_useless_paths)
311eb8dc403SDave Cobbley    tar.close()
312eb8dc403SDave Cobbley
313eb8dc403SDave Cobbley# creating .diff.gz between source.orig and source
314eb8dc403SDave Cobbleydef create_diff_gz(d, src_orig, src, ar_outdir):
315eb8dc403SDave Cobbley
316eb8dc403SDave Cobbley    import subprocess
317eb8dc403SDave Cobbley
318eb8dc403SDave Cobbley    if not os.path.isdir(src) or not os.path.isdir(src_orig):
319eb8dc403SDave Cobbley        return
320eb8dc403SDave Cobbley
321eb8dc403SDave Cobbley    # The diff --exclude can't exclude the file with path, so we copy
322eb8dc403SDave Cobbley    # the patched source, and remove the files that we'd like to
323eb8dc403SDave Cobbley    # exclude.
324eb8dc403SDave Cobbley    src_patched = src + '.patched'
325eb8dc403SDave Cobbley    oe.path.copyhardlinktree(src, src_patched)
326eb8dc403SDave Cobbley    for i in d.getVarFlag('ARCHIVER_MODE', 'diff-exclude').split():
327eb8dc403SDave Cobbley        bb.utils.remove(os.path.join(src_orig, i), recurse=True)
328eb8dc403SDave Cobbley        bb.utils.remove(os.path.join(src_patched, i), recurse=True)
329eb8dc403SDave Cobbley
330eb8dc403SDave Cobbley    dirname = os.path.dirname(src)
331eb8dc403SDave Cobbley    basename = os.path.basename(src)
332eb8dc403SDave Cobbley    bb.utils.mkdirhier(ar_outdir)
333eb8dc403SDave Cobbley    cwd = os.getcwd()
334eb8dc403SDave Cobbley    try:
335eb8dc403SDave Cobbley        os.chdir(dirname)
336eb8dc403SDave Cobbley        out_file = os.path.join(ar_outdir, '%s-diff.gz' % d.getVar('PF'))
337eb8dc403SDave Cobbley        diff_cmd = 'diff -Naur %s.orig %s.patched | gzip -c > %s' % (basename, basename, out_file)
338eb8dc403SDave Cobbley        subprocess.check_call(diff_cmd, shell=True)
339eb8dc403SDave Cobbley        bb.utils.remove(src_patched, recurse=True)
340eb8dc403SDave Cobbley    finally:
341eb8dc403SDave Cobbley        os.chdir(cwd)
342eb8dc403SDave Cobbley
343eb8dc403SDave Cobbleydef is_work_shared(d):
344eb8dc403SDave Cobbley    pn = d.getVar('PN')
345eb8dc403SDave Cobbley    return bb.data.inherits_class('kernel', d) or pn.startswith('gcc-source')
346eb8dc403SDave Cobbley
347eb8dc403SDave Cobbley# Run do_unpack and do_patch
348eb8dc403SDave Cobbleypython do_unpack_and_patch() {
349eb8dc403SDave Cobbley    if d.getVarFlag('ARCHIVER_MODE', 'src') not in \
350eb8dc403SDave Cobbley            [ 'patched', 'configured'] and \
351eb8dc403SDave Cobbley            d.getVarFlag('ARCHIVER_MODE', 'diff') != '1':
352eb8dc403SDave Cobbley        return
353eb8dc403SDave Cobbley    ar_outdir = d.getVar('ARCHIVER_OUTDIR')
354eb8dc403SDave Cobbley    ar_workdir = d.getVar('ARCHIVER_WORKDIR')
355eb8dc403SDave Cobbley    ar_sysroot_native = d.getVar('STAGING_DIR_NATIVE')
356eb8dc403SDave Cobbley    pn = d.getVar('PN')
357eb8dc403SDave Cobbley
358eb8dc403SDave Cobbley    # The kernel class functions require it to be on work-shared, so we dont change WORKDIR
359eb8dc403SDave Cobbley    if not is_work_shared(d):
360eb8dc403SDave Cobbley        # Change the WORKDIR to make do_unpack do_patch run in another dir.
361eb8dc403SDave Cobbley        d.setVar('WORKDIR', ar_workdir)
362eb8dc403SDave Cobbley        # Restore the original path to recipe's native sysroot (it's relative to WORKDIR).
363eb8dc403SDave Cobbley        d.setVar('STAGING_DIR_NATIVE', ar_sysroot_native)
364eb8dc403SDave Cobbley
365eb8dc403SDave Cobbley        # The changed 'WORKDIR' also caused 'B' changed, create dir 'B' for the
366eb8dc403SDave Cobbley        # possibly requiring of the following tasks (such as some recipes's
367eb8dc403SDave Cobbley        # do_patch required 'B' existed).
368eb8dc403SDave Cobbley        bb.utils.mkdirhier(d.getVar('B'))
369eb8dc403SDave Cobbley
370eb8dc403SDave Cobbley        bb.build.exec_func('do_unpack', d)
371eb8dc403SDave Cobbley
372eb8dc403SDave Cobbley    # Save the original source for creating the patches
373eb8dc403SDave Cobbley    if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1':
374eb8dc403SDave Cobbley        src = d.getVar('S').rstrip('/')
375eb8dc403SDave Cobbley        src_orig = '%s.orig' % src
376eb8dc403SDave Cobbley        oe.path.copytree(src, src_orig)
377eb8dc403SDave Cobbley
378eb8dc403SDave Cobbley    # Make sure gcc and kernel sources are patched only once
379eb8dc403SDave Cobbley    if not (d.getVar('SRC_URI') == "" or is_work_shared(d)):
380eb8dc403SDave Cobbley        bb.build.exec_func('do_patch', d)
381eb8dc403SDave Cobbley
382eb8dc403SDave Cobbley    # Create the patches
383eb8dc403SDave Cobbley    if d.getVarFlag('ARCHIVER_MODE', 'diff') == '1':
384eb8dc403SDave Cobbley        bb.note('Creating diff gz...')
385eb8dc403SDave Cobbley        create_diff_gz(d, src_orig, src, ar_outdir)
386eb8dc403SDave Cobbley        bb.utils.remove(src_orig, recurse=True)
387eb8dc403SDave Cobbley}
388eb8dc403SDave Cobbley
389eb8dc403SDave Cobbley# BBINCLUDED is special (excluded from basehash signature
390eb8dc403SDave Cobbley# calculation). Using it in a task signature can cause "basehash
391eb8dc403SDave Cobbley# changed" errors.
392eb8dc403SDave Cobbley#
393eb8dc403SDave Cobbley# Depending on BBINCLUDED also causes do_ar_recipe to run again
394eb8dc403SDave Cobbley# for unrelated changes, like adding or removing buildhistory.bbclass.
395eb8dc403SDave Cobbley#
396eb8dc403SDave Cobbley# For these reasons we ignore the dependency completely. The versioning
397eb8dc403SDave Cobbley# of the output file ensures that we create it each time the recipe
398eb8dc403SDave Cobbley# gets rebuilt, at least as long as a PR server is used. We also rely
399eb8dc403SDave Cobbley# on that mechanism to catch changes in the file content, because the
400eb8dc403SDave Cobbley# file content is not part of of the task signature either.
401eb8dc403SDave Cobbleydo_ar_recipe[vardepsexclude] += "BBINCLUDED"
402eb8dc403SDave Cobbleypython do_ar_recipe () {
403eb8dc403SDave Cobbley    """
404eb8dc403SDave Cobbley    archive the recipe, including .bb and .inc.
405eb8dc403SDave Cobbley    """
406eb8dc403SDave Cobbley    import re
407eb8dc403SDave Cobbley    import shutil
408eb8dc403SDave Cobbley
409eb8dc403SDave Cobbley    require_re = re.compile( r"require\s+(.+)" )
410eb8dc403SDave Cobbley    include_re = re.compile( r"include\s+(.+)" )
411eb8dc403SDave Cobbley    bbfile = d.getVar('FILE')
412eb8dc403SDave Cobbley    outdir = os.path.join(d.getVar('WORKDIR'), \
413eb8dc403SDave Cobbley            '%s-recipe' % d.getVar('PF'))
414eb8dc403SDave Cobbley    bb.utils.mkdirhier(outdir)
415eb8dc403SDave Cobbley    shutil.copy(bbfile, outdir)
416eb8dc403SDave Cobbley
417eb8dc403SDave Cobbley    pn = d.getVar('PN')
418eb8dc403SDave Cobbley    bbappend_files = d.getVar('BBINCLUDED').split()
419eb8dc403SDave Cobbley    # If recipe name is aa, we need to match files like aa.bbappend and aa_1.1.bbappend
420eb8dc403SDave Cobbley    # Files like aa1.bbappend or aa1_1.1.bbappend must be excluded.
421eb8dc403SDave Cobbley    bbappend_re = re.compile( r".*/%s_[^/]*\.bbappend$" % re.escape(pn))
422eb8dc403SDave Cobbley    bbappend_re1 = re.compile( r".*/%s\.bbappend$" % re.escape(pn))
423eb8dc403SDave Cobbley    for file in bbappend_files:
424eb8dc403SDave Cobbley        if bbappend_re.match(file) or bbappend_re1.match(file):
425eb8dc403SDave Cobbley            shutil.copy(file, outdir)
426eb8dc403SDave Cobbley
427eb8dc403SDave Cobbley    dirname = os.path.dirname(bbfile)
428eb8dc403SDave Cobbley    bbpath = '%s:%s' % (dirname, d.getVar('BBPATH'))
429eb8dc403SDave Cobbley    f = open(bbfile, 'r')
430eb8dc403SDave Cobbley    for line in f.readlines():
431eb8dc403SDave Cobbley        incfile = None
432eb8dc403SDave Cobbley        if require_re.match(line):
433eb8dc403SDave Cobbley            incfile = require_re.match(line).group(1)
434eb8dc403SDave Cobbley        elif include_re.match(line):
435eb8dc403SDave Cobbley            incfile = include_re.match(line).group(1)
436eb8dc403SDave Cobbley        if incfile:
437eb8dc403SDave Cobbley            incfile = d.expand(incfile)
438eb8dc403SDave Cobbley            incfile = bb.utils.which(bbpath, incfile)
439eb8dc403SDave Cobbley            if incfile:
440eb8dc403SDave Cobbley                shutil.copy(incfile, outdir)
441eb8dc403SDave Cobbley
442eb8dc403SDave Cobbley    create_tarball(d, outdir, 'recipe', d.getVar('ARCHIVER_OUTDIR'))
443eb8dc403SDave Cobbley    bb.utils.remove(outdir, recurse=True)
444eb8dc403SDave Cobbley}
445eb8dc403SDave Cobbley
446eb8dc403SDave Cobbleypython do_dumpdata () {
447eb8dc403SDave Cobbley    """
448eb8dc403SDave Cobbley    dump environment data to ${PF}-showdata.dump
449eb8dc403SDave Cobbley    """
450eb8dc403SDave Cobbley
451eb8dc403SDave Cobbley    dumpfile = os.path.join(d.getVar('ARCHIVER_OUTDIR'), \
452eb8dc403SDave Cobbley        '%s-showdata.dump' % d.getVar('PF'))
453eb8dc403SDave Cobbley    bb.note('Dumping metadata into %s' % dumpfile)
454eb8dc403SDave Cobbley    with open(dumpfile, "w") as f:
455eb8dc403SDave Cobbley        # emit variables and shell functions
456eb8dc403SDave Cobbley        bb.data.emit_env(f, d, True)
457eb8dc403SDave Cobbley        # emit the metadata which isn't valid shell
458eb8dc403SDave Cobbley        for e in d.keys():
459eb8dc403SDave Cobbley            if d.getVarFlag(e, "python", False):
460eb8dc403SDave Cobbley                f.write("\npython %s () {\n%s}\n" % (e, d.getVar(e, False)))
461eb8dc403SDave Cobbley}
462eb8dc403SDave Cobbley
463eb8dc403SDave CobbleySSTATETASKS += "do_deploy_archives"
464eb8dc403SDave Cobbleydo_deploy_archives () {
465eb8dc403SDave Cobbley    echo "Deploying source archive files from ${ARCHIVER_TOPDIR} to ${DEPLOY_DIR_SRC}."
466eb8dc403SDave Cobbley}
467eb8dc403SDave Cobbleypython do_deploy_archives_setscene () {
468eb8dc403SDave Cobbley    sstate_setscene(d)
469eb8dc403SDave Cobbley}
470eb8dc403SDave Cobbleydo_deploy_archives[dirs] = "${ARCHIVER_TOPDIR}"
471eb8dc403SDave Cobbleydo_deploy_archives[sstate-inputdirs] = "${ARCHIVER_TOPDIR}"
472eb8dc403SDave Cobbleydo_deploy_archives[sstate-outputdirs] = "${DEPLOY_DIR_SRC}"
473eb8dc403SDave Cobbleyaddtask do_deploy_archives_setscene
474eb8dc403SDave Cobbley
475eb8dc403SDave Cobbleyaddtask do_ar_original after do_unpack
476eb8dc403SDave Cobbleyaddtask do_unpack_and_patch after do_patch
477eb8dc403SDave Cobbleyaddtask do_ar_patched after do_unpack_and_patch
478eb8dc403SDave Cobbleyaddtask do_ar_configured after do_unpack_and_patch
479eb8dc403SDave Cobbleyaddtask do_dumpdata
480eb8dc403SDave Cobbleyaddtask do_ar_recipe
481eb8dc403SDave Cobbleyaddtask do_deploy_archives before do_build
482eb8dc403SDave Cobbley
483eb8dc403SDave Cobbleypython () {
484eb8dc403SDave Cobbley    # Add tasks in the correct order, specifically for linux-yocto to avoid race condition.
485eb8dc403SDave Cobbley    # sstatesig.py:sstate_rundepfilter has special support that excludes this dependency
486eb8dc403SDave Cobbley    # so that do_kernel_configme does not need to run again when do_unpack_and_patch
487eb8dc403SDave Cobbley    # gets added or removed (by adding or removing archiver.bbclass).
488eb8dc403SDave Cobbley    if bb.data.inherits_class('kernel-yocto', d):
489eb8dc403SDave Cobbley        bb.build.addtask('do_kernel_configme', 'do_configure', 'do_unpack_and_patch', d)
490eb8dc403SDave Cobbley}
491