1#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7ROOTFS_BOOTSTRAP_INSTALL = ""
8IMAGE_TYPES_MASKED += "container"
9IMAGE_TYPEDEP:container = "tar.bz2"
10
11python __anonymous() {
12    if "container" in d.getVar("IMAGE_FSTYPES") and \
13       d.getVar("IMAGE_CONTAINER_NO_DUMMY") != "1" and \
14       "linux-dummy" not in d.getVar("PREFERRED_PROVIDER_virtual/kernel"):
15        msg = '"container" is in IMAGE_FSTYPES, but ' \
16              'PREFERRED_PROVIDER_virtual/kernel is not "linux-dummy". ' \
17              'Unless a particular kernel is needed, using linux-dummy will ' \
18              'prevent a kernel from being built, which can reduce ' \
19              'build times. If you don\'t want to use "linux-dummy", set ' \
20              '"IMAGE_CONTAINER_NO_DUMMY" to "1".'
21
22        # Raising skip recipe was Paul's clever idea. It causes the error to
23        # only be shown for the recipes actually requested to build, rather
24        # than bb.fatal which would appear for all recipes inheriting the
25        # class.
26        raise bb.parse.SkipRecipe(msg)
27}
28